Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-17-2010, 05:36 AM
ruphous4 ruphous4 is offline
Learning to use the forums
 
Join Date: May 2010
Posts: 1
Default 2003 4-cyl power problem

I have a 2003 4-cyl manual transmission ranger 190,000 miles. I am having a problem when I fill the gas tank, I can go about 1/10 mile before I lose power, even with accelerator to the floor. I have to put it in neutral, turn it off, then back on to go another 1/10 mile or so. I have been having this problem for a couple of weeks. When the fuel level gets down to 1/4, it runs fine. I replaced both 02 sensors.
Reply With Quote
  #2  
Old 05-17-2010, 08:29 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 2003 4-cyl power problem

Quote:
Originally Posted by ruphous4 View Post
I have a 2003 4-cyl manual transmission ranger 190,000 miles. I am having a problem when I fill the gas tank, I can go about 1/10 mile before I lose power, even with accelerator to the floor. I have to put it in neutral, turn it off, then back on to go another 1/10 mile or so. I have been having this problem for a couple of weeks. When the fuel level gets down to 1/4, it runs fine. I replaced both 02 sensors.
the problem is not your o2 sensors but with all those miles it is a good idea to change them anyways. I don't know your problem., however I would do a fuel pressure test and see what you got. do a koeo, koer and see how many psi it drops after you turn it off( this checks for leaks and or a bad check valve). I wonder if it could be something as simple as a bad gas cap. I did you check for codes even pending codes?

*throw some Techron in the tank
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 05-17-2010 at 08:30 AM. Reason: *
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 Ford Ranger Pickup 4-cyl stick. The problem is the clutch. As I let out the... Will Ferrel Drivetrain Tech 11 04-07-2011 11:34 AM
3.0L misfire in cyl #3 fdmn65 3.0 Vulcan Tech 4 10-08-2010 06:28 AM
Ranger 2003 (2,5L Diesel) problem heze1982 4-Cylinder Tech 2 02-07-2010 07:48 AM
new member - ranger problem 2003 -3.0L diamondx General Ford Ranger Discussion 5 12-15-2009 02:17 PM
99 ranger power windows problem patterson302 Electrical Tech 2 07-06-2009 10:09 PM