Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-15-2010, 06:27 PM
kenmiller59 kenmiller59 is offline
Learning to use the forums
 
Join Date: May 2010
Posts: 3
Default 87 2.3L FI 4 Cylinder -

Hello.....I have a 1987 2.3L FI 4 cylinder (rebuilt with 40k on the rebuild).....The engine idles very rough and seems to miss at low RPMs, has no power, exhaust smells wrong after it runs for a few minutes and drinks gas like crazy(runnin rich)!!!........Any suggestions!!.....Oh yeah, emmissions light is on on the dash.........I just replaced the MAP sensor...I have recently replaced the Idle Air Control valve, EGR valve, EGR position sensor...........Hasn't improved at all!!.......Suggestions are welcome!!!!!!!!

Thanks.....Ken - North Carolina
Reply With Quote
  #2  
Old 05-17-2010, 09:15 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 87 2.3L FI 4 Cylinder -

Quote:
Originally Posted by kenmiller59 View Post
Hello.....I have a 1987 2.3L FI 4 cylinder (rebuilt with 40k on the rebuild).....The engine idles very rough and seems to miss at low RPMs, has no power, exhaust smells wrong after it runs for a few minutes and drinks gas like crazy(runnin rich)!!!........Any suggestions!!.....Oh yeah, emmissions light is on on the dash.........I just replaced the MAP sensor...I have recently replaced the Idle Air Control valve, EGR valve, EGR position sensor...........Hasn't improved at all!!.......Suggestions are welcome!!!!!!!!

Thanks.....Ken - North Carolina
did you read the codes?.sounds like it could be an o2 sensor but I would read the codes before I did anything............
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
cylinder 5 misfire brendaprz General Tech 5 08-06-2011 04:20 PM
slave cylinder RangerLuc General Ford Ranger Discussion 25 04-08-2011 08:36 AM
MISFIRE in Cylinder 6 RangerSteve 3.0 Vulcan Tech 16 02-28-2010 05:12 PM
MISFIRE in Cylinder 6 RangerSteve 3.0 Vulcan Tech 3 02-08-2010 05:58 PM
#2 cylinder missing Boujiboy2000 3.0 Vulcan Tech 2 11-02-2009 04:24 PM