Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-08-2013, 12:13 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default 2.5 rpms stay high while switching gears, doesnt when speed sensor disconnected

I just bought the truck last week to get back and forth to work. When I got it the speedometer/wiper/domelight fuse was missing. When I put it in everything worked including the speedo, however with the fuse in when i shift gears the rpms stay very high and dont come down until I stop. Is this a defective speed sensor or abs speed sensor? Any help would be great! I wouldn't mind no speedo but the wipers are on same fuse
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
  #2  
Old 12-08-2013, 01:19 PM
stateranger stateranger is offline
Mr H....A....P...P....Y👿
 
Join Date: Nov 2012
Posts: 2,896
Default Re: 2.5 rpms stay high while switching gears, doesnt when speed sensor disconnected

Define very high rpm. 1, 100-1,500 is normal because the ecu is rpm matching for an expected gear change.
__________________
2014 F150 xl 3.7 6 speed auto.

Quote:
Originally Posted by pk9298 View Post
HELL TO THE NO!! Abort abort abort!! That's the first thing to go!!! Ewwwww! I'm not no vampire! I don't enjoy red tea
Reply With Quote
  #3  
Old 12-08-2013, 01:29 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default

I dont have a tach so I dont know exactly, id guess 3500. Its definitely not normal, when that speedo fuse is taken out its normal thata why I'm guessing I just need a speed sensor. It also idles pretty rough but doesnt have any cels
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
  #4  
Old 12-08-2013, 01:31 PM
pcityranger pcityranger is offline
Ford Ranger Driver
 
Join Date: Feb 2011
Posts: 1,206
Default Re: 2.5 rpms stay high while switching gears, doesnt when speed sensor disconnected

Check the idle air control, also try disconnecting the ground to the battery and re setting the comp.
__________________
2004 4.0 4x4 5spd xlt with 175k 4.10 axles, extended cab, cranked t-bars (not maxed), painted black interior, 32x11.5x15 bfg a/t and procomp steel rims
60/40 mod with a shorty console
Reply With Quote
  #5  
Old 12-08-2013, 02:15 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default

I replaced iac and reset ecu. It didnt help. Only thing that has helped is taking out speedo fuse
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
  #6  
Old 12-08-2013, 02:18 PM
AnythingCanHappen AnythingCanHappen is offline
and AnythingWillHappen
 
Join Date: Oct 2012
Posts: 3,538
Default

Quote:
Originally Posted by kyranger98 View Post
I replaced iac and reset ecu. It didnt help. Only thing that has helped is taking out speedo fuse
Did you check for any codes? You say the light didn't come on but the build could be taken out or blown
__________________
2010 Fx4 F150
2003 Ford SVT Cobra
2000 Ford Ranger XLT 4x4 Offroad =====SOLD
5.0 V8 with L/S 4.10's and a lot of other crap
Reply With Quote
  #7  
Old 12-08-2013, 02:23 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default

It works it comes on when I take out speedo fuse
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
  #8  
Old 12-08-2013, 03:00 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default

Is it no weird that it doesnt do it when I unplug speedo?
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
  #9  
Old 12-08-2013, 04:22 PM
stateranger stateranger is offline
Mr H....A....P...P....Y👿
 
Join Date: Nov 2012
Posts: 2,896
Default Re: 2.5 rpms stay high while switching gears, doesnt when speed sensor disconnected

Quote:
Originally Posted by kyranger98 View Post
I dont have a tach so I dont know exactly id guess 3500. Its definitely not normal, when that speedo fuse is taken out its normal thata why I'm guessing I just need a speed sensor. It also idles pretty rough but doesnt have any cels
If the plugs, wires,and fuel filter haven't been done replace them and check for codes. The speed sensor sends a signal to the ecu and the ecu opens the idle air control while the vehicle is moving. If the abs light isnt on or the speedo isn't jumping around the sensor is fine. Speedsensor will have an abs code.
__________________
2014 F150 xl 3.7 6 speed auto.

Quote:
Originally Posted by pk9298 View Post
HELL TO THE NO!! Abort abort abort!! That's the first thing to go!!! Ewwwww! I'm not no vampire! I don't enjoy red tea
Reply With Quote
  #10  
Old 12-08-2013, 04:25 PM
kyranger98 kyranger98 is offline
Ford Truck Driver
 
Join Date: Dec 2013
Posts: 77
Default

Ok i will try that still doesnt make since to me why it is fine with speedo unplugged? Could it be the egr valve or solenoid?
__________________
98 ranger xlt 2.5 2wd single cab 5 speed
Reply With Quote
Reply

Tags
high rpm, speed sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
RPMs stay high (or even get higher) when shifting 5-speed 94mtx 4-Cylinder Tech 33 02-10-2014 08:26 PM
Yellow fluid in the snow after switching to 4x4 high gordonsimmons Drivetrain Tech 11 12-30-2012 08:29 AM
RPMs do not decrease between gears Chasman 4.0 SOHC / 4.0 OHV Tech 4 07-14-2012 01:26 AM
Bogging at high rpms. HELP PLEASE! Alex32 2.9 Liter Tech 4 05-09-2012 06:19 AM
High rpms Johngault 4-Cylinder Tech 1 10-24-2009 02:46 PM