Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-31-2010, 10:20 AM
leachtyler leachtyler is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 7
Default Oil Issue x{


My name is Tyler and I just bought a 88 ford ranger with only 68k miles. I put too much oil in it on accident and a black hose popped off the relieve pressure and oil went everywhere. Me and my uncle spent all night on a friday trying to get that hose back on. Once we got it on the truck started up good, smoked a little burning the oil off inside the engine but other then that it seems fine. BUT the oil light keeps comming on and and I stop and pull over and check the hose and the oil level it is all fine. Then when I start the truck back up the oil light is off. Any ideas on this or what I should/could/need to do to get this truck back in shape?
Reply With Quote
Old 04-11-2010, 02:06 PM
CivicKiller-16 CivicKiller-16 is offline
Ford Ranger Owner
Join Date: Feb 2010
Posts: 72
Default Re: Oil Issue x{

putting 2 much oil can be as devestateing as not puting enough.. what motor is
2007 ranger 2.3 5 speed "civic killer" 1961 jeep cj-5 REDNECK RICER [><] "If a leave here tomorrow will you still remember me" Lynyrd Skynyrd 4 ever
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiper Issue Mike Electrical Tech 4 06-23-2010 10:20 PM
03 2.3L bog issue kschaffner 4-Cylinder Tech 0 02-14-2010 04:33 PM
new 4x4 issue Kayledao Drivetrain Tech 3 09-05-2009 01:42 AM
offset issue.. CALI-RANGER Wheels and Tires 9 06-22-2009 05:12 AM
hid issue sprtyboy Electrical Tech 1 05-24-2009 07:27 PM