Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 04-15-2010, 08:23 AM
stephensimmons stephensimmons is offline
Ford Truck Driver
 
Join Date: Apr 2010
Posts: 87
Default Re: 93 ranger 2.3l loss of power

Mine was the ignition module on the side of the intake with the plug on the top and one on the bottom.
Reply With Quote
  #32  
Old 04-15-2010, 10:34 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: 93 ranger 2.3l loss of power

Thats what made your bog out?
Reply With Quote
  #33  
Old 04-15-2010, 11:00 PM
94lowranger 94lowranger is offline
Fords All the way
 
Join Date: Jan 2010
Posts: 9
Default Re: 93 ranger 2.3l loss of power

Check on your firewall there is two vacuum hoses that run up to a silver box, check both of thoses that was wrong with mine and plug them on and put zip ties on them at both ends. perfect fix mine hasnt had a problem since
__________________
1986 Ford F150
302 5.0 V8
Reply With Quote
  #34  
Old 04-16-2010, 09:05 AM
Saithin Saithin is offline
Corporate Slave
 
Join Date: Apr 2010
Posts: 26
Default Re: 93 ranger 2.3l loss of power

I had the same problem, I have 250k-ish on my 93 xlt. I just started babing it. after a tune up. New plugs, wires, good oil,keep an eye on the transmission oil, new cat, and I changed the fule filter. and added techron injector cleaner to the tank, fairlly strong mix (seafoam should work too), and kept the AC off. I have enough power to pull my boat. But I change my oil every 2k miles just because I want to make sure the thing stays around for another 100k miles.
Reply With Quote
  #35  
Old 04-17-2010, 05:52 AM
stephensimmons stephensimmons is offline
Ford Truck Driver
 
Join Date: Apr 2010
Posts: 87
Default Re: 93 ranger 2.3l loss of power

Quote:
Originally Posted by Clinton View Post
Thats what made your bog out?
Yes it has something to do with the timing. It would almost die when i shift it to fifth even at 60mph so i had to drive around in forth unless i was driving 70mph then i could go to fifth. Now i can shift fifth at 50mph and it dont die on me and i got 240xxx on mine.
Reply With Quote
  #36  
Old 04-20-2010, 06:24 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: 93 ranger 2.3l loss of power

What about when its idling in neutral? I hit the gas and it bogs down, sounds like its clogged or something
Reply With Quote
  #37  
Old 04-20-2010, 07:18 PM
stephensimmons stephensimmons is offline
Ford Truck Driver
 
Join Date: Apr 2010
Posts: 87
Default Re: 93 ranger 2.3l loss of power

Quote:
Originally Posted by Clinton View Post
What about when its idling in neutral? I hit the gas and it bogs down, sounds like its clogged or something
That could be your throttle positioning sensor going bad
Reply With Quote
  #38  
Old 04-24-2010, 04:52 AM
mr cribb mr cribb is offline
Ford Ranger Owner
 
Join Date: Oct 2009
Posts: 62
Default Re: 93 ranger 2.3l loss of power

I have a 94 same motor with tons more miles... I would look into the t-belt, because you said one thing that caught my attention....it backfires if i rev it really hard..... Sounds like the timing is just slightly off. I attempted to do my belt last weekend and couldn't get my crank bolt loose and the belt advanced two teeth.....little bit** runs better than ever....LOL mine was down on power, but it's more coil related cause everything else is replaced and my coils still have the famous "motorcraft" on them.
__________________
1994 sun faded (New Mexico/Texas truck) maroon, regular cab, 2.3 5 speed & 3.73's. Bought w/ 227k and climbing.
Reply With Quote
  #39  
Old 04-27-2010, 08:31 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: 93 ranger 2.3l loss of power

Ok.....it's solved! less than 24 hours in a shop, i feel like an ass. Turns out half the coil fot the wires was shot, bad wires and some of the plugs were literally falling apart! Spending all that money on the parts i put on myself i kick myself for not taking it to a shop but it's finally fixed and i got alot of new patts for my 93 Ranger to keep going! Thanks for all the help guys and standby because my 01 Ranger XLT is getting a 3 inch body kit and gap guards!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle (sometimes), loss of power - 97 Ranger matic00 4-Cylinder Tech 6 04-18-2012 09:58 AM
93 4.ol loss of power kiwimike 4.0 SOHC / 4.0 OHV Tech 0 01-08-2012 03:20 PM
Power loss? miller Wheels and Tires 2 09-20-2011 08:21 PM
Help 1999 Ranger Inconsistent Sudden loss of power 99Flex 3.0 Vulcan Tech 4 01-25-2011 08:54 PM
1999 ranger power loss tamochin 3.0 Vulcan Tech 14 12-01-2010 06:43 PM