Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-31-2013, 10:16 PM
wilkcards wilkcards is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2013
Posts: 15
Default Runaway 99 Ranger

I've been fixing up my 99 ranger, and had a bit of a scary problem. The car was accelerating w/o me putting my foot on the gas. I had to ride the brake to keep from continually gaining speed. It seems like as the rpms get pushed up, they don't come down.
Even in neutral, or park the rpms stay up.
What should be my first step? Clean/replace IAC? Clean throttle body? I don't know anyone with a computer i can connect it to, and wouldn't feel safe driving it to autozone or anywhere else.
Reply With Quote
  #2  
Old 08-31-2013, 10:28 PM
99Ranger376 99Ranger376 is offline
Still around
 
Join Date: Jun 2012
Posts: 2,296
Default Re: Runaway 99 Ranger

welcome to FRF I would clean the throttle body also check for a vacuum leak or intake gasket leak
__________________
2011 Ranger XLT 4x4 3.73 8.8" Trac-lok #1 T-bars, K -springs, LineX bedliner, General Grabber AT2's, Tonnopro tri-fold, CoverKing Realtree AP seat covers, OEM pre-keys, axle spacers, Bilstein 4600's, Hellwig AAL. Ziebart Undercoat
'98 Ranger XLT 2WD (sold)
Reply With Quote
  #3  
Old 08-31-2013, 10:50 PM
wilkcards wilkcards is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2013
Posts: 15
Default Re: Runaway 99 Ranger

Thanks, I'll do that.
Reply With Quote
  #4  
Old 09-01-2013, 05:06 AM
svtwin73 svtwin73 is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 310
Default Re: Runaway 99 Ranger

Take the intake tube off and check the throttle body and linkage. I had this happen on my old 93 Ranger, it just got stuck.
__________________
1998 Ranger Supercab 4.0L, Medium Metallic XLT, auto, painted valve covers (10 HP), 30x9.5/15.

2008 Mustang GT, stroked 5.0 3v, RGR cams, R2300 S/C, suspension, Kooks LTs w/HF cats GT500 TB, Flowmaster cat-back exhaust, GT500 fuel pump setup.
Reply With Quote
  #5  
Old 09-01-2013, 12:18 PM
wilkcards wilkcards is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2013
Posts: 15
Default

I took the throttle intake tube off, and the valve was very dirty. I sprayed with carb cleaner and brushed with toothbrush until clean

I then disconnected maf, throttle control sensor, iac sensor etc, cleaned with electric cleaner, and the put dialytic grease on all connections.

I also sprayed throttle spring/assembly with oil and moved it back and forth which seemed to loosen It up a lot. When I first checked it it was stuck open.

Anyways, I put it all back together and it idles around 800rpm and seems to drive normally again

Thanks for the help! I'm sure I'll be back soon
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search