Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-09-2010, 08:25 AM
srl srl is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 1
Default 2004 Ranger 4.0L cold start hesitation

I've had a problem with my 04 ranger, 4.0L, AT, since I bought it new. I took it into two different dealers while it was under warranty, but neither was able to resolve the problem.
When I cold start my ranger, I will experience a hesitation when I'm driving between 35 and 45 mph. This happens every day, regardless of the outside temperature, unless the truck idles long enough before driving (while I'm scraping ice of the windows, etc.), or if the first 5 minutes or so of driving is at 30mph or slower. It continues for 30 seconds to 1 minute. There is never a problem starting the vehicle, it's never died, and it never idles rough.
After visits to two dealers with no success, I've just been living with this minor annoyance for over 6 years.
Now that I'm thinking of selling it, I'd like to take care of it and be able to hand over a clean, smooth running vehicle to whoever buys it.

Anybody else seen this? I did find a Ford TSB, 10008550, which talks about a cold start surge/hesitation problem, but couldn't find any other info to help determine a resolution.

Thanks to anybody who can point me in the right direction.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine ticking Cold start 98 X Cab 4-Cylinder Tech 6 02-22-2012 01:15 PM
no start when cold dragon_reaper 4-Cylinder Tech 3 11-24-2010 11:38 PM
No start when cold, not even with a jump Daedalus General Tech 23 05-24-2010 12:38 PM
92 Ranger 2.3L Acceleration Hesitation Tom M 4-Cylinder Tech 2 03-02-2010 06:14 PM
Intermittent hard start when cold mj1287 4.0 SOHC / 4.0 OHV Tech 5 10-29-2009 12:26 PM