Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-08-2010, 10:58 AM
muddyranger muddyranger is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 12
Unhappy loss of low end power

ok, i recently put some STL injector cleaner in my tank and imedeatly noticed that when i roll on the gas it keeps up just fine. but when i put er to the floor it gets to about 2 grand and bogs and jumps everywhere. like it's getting spurts of power all through 2500 to 5000 rpms. possibilities? i was thinking sparkplugs not burning efficiently, plug wires not sending well, clutch slippage(really dont know what that feels like so thats a swag)? any suggestions would be appreciated.


PS i did run that tank out and filled up with another because i thought the injector cleaner could have raised the octane and messed with it there
__________________
93 xlt 5spd. 4.0L 4x4 172xxx and still counting!!
Reply With Quote
  #2  
Old 03-08-2010, 02:05 PM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Default Re: loss of low end power

check the plugs, additives can leave a bunch of junk on them.
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #3  
Old 03-08-2010, 02:26 PM
Jp7 Jp7 is offline
DISABLE ADBLOCK: LOLZ
 
Join Date: Dec 2009
Posts: 1,438
Default Re: loss of low end power

reset fuel trims after cleaning
__________________
Looking for a professional retrofitter to add HIDs or LEDs to your Ranger? PM me if your looking to have work done, and have cash to spend.

Quote:
Originally Posted by FireRanger View Post
I'm dying to see this at night. Someone go tell the sun to give up already.
Quote:
Originally Posted by beef08 View Post
Your the man, you bring our dreams to a reality within the lighting spectrum
Quote:
Originally Posted by BCobe View Post
Jp7 you always do AMAZING work! Hats off to you sir
Quote:
Originally Posted by FireRanger View Post
People so often confuse "hating" with "knowing better".
Reply With Quote
  #4  
Old 03-08-2010, 08:00 PM
muddyranger muddyranger is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 12
Default Re: loss of low end power

ok, so i was doing a little researching and i might have it figured. could it possibly be the Mass Airflow Sensor? i know that especially on the 4.0 it gets dirty or clogged or whatever pretty quick and then it reads the amount of air going to the fuel mixture therefor making it bog. they say to clean it every 25k. on the right track?
__________________
93 xlt 5spd. 4.0L 4x4 172xxx and still counting!!
Reply With Quote
  #5  
Old 03-08-2010, 08:22 PM
BigT8600 BigT8600 is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 234
Default Re: loss of low end power

If you have never cleaned it, and you have that many miles on your truck, then it sure as hell wont hurt to clean it. I cleaned mine. Didn't notice a lot that happened but it did have some mud in it. Here is a link regarding cleaning the MAF:
Mass Airflow Sensor
__________________
~-SOLD-~
04' Edge 6 Cyl 3.0 5 Speed Manual 107K Miles
3" Body Lift - 33" All Terrain Tires
Drop In K&N Filter - Flowmaster - XM Commander Satellite Radio
Reply With Quote
  #6  
Old 03-08-2010, 09:35 PM
Coleosis Coleosis is offline
The Sickest
 
Join Date: Jun 2009
Posts: 451
Default Re: loss of low end power

same thing happened to me in a fullsize chevy after I ran it out of gas. Though it would sometimes stall out and completely die if I stomped on the gas. Replaced fuel pump and filter and it fixed it....Have you ran your truck out of gas lately? Cleaning the MAF would be a better place to start though.
Reply With Quote
  #7  
Old 03-09-2010, 09:56 AM
muddyranger muddyranger is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 12
Default

i'm definitely gonna clean teh MAF, think i'll replace the plugs and wires too. just to be sure. when they say "electronic parts cleaner" where can i get it?

also, where can i get some hex keys that have the hollow tips? are they specialized tools or just everyday and i'm being an airhead? lol
__________________
93 xlt 5spd. 4.0L 4x4 172xxx and still counting!!
Reply With Quote
  #8  
Old 03-09-2010, 12:12 PM
4.0fan 4.0fan is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 44
Default Re: loss of low end power

haha.. they are a specialty tool but you can pretty much get it from any aauto parts stores..same with the electronic parts cleaner.. there is some stuff that is actually called MAf cleaner..just go to the auto parts store
__________________
Never Give In, Never Give Up. Ride Hard, Die Hard
Reply With Quote
  #9  
Old 03-30-2010, 03:35 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: loss of low end power

I have cleaned my MAF because i had the same problem. You can clean the elctrodes by soaking it in white vinagar for 8 hours and use an air gun to dry it off. I did that a few times and even replaced the MAF and i still have the same problem. I got my hex keys at walmart, came with a bunch of different tips for an insert screw driver and works great.
Reply With Quote
  #10  
Old 05-09-2010, 06:49 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: loss of low end power

ok, just so you know the problem was solved! turns out it had 1 bad coil, and the spark plugs were literally falling apart, now it runs great!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 ranger power loss tamochin 3.0 Vulcan Tech 14 12-01-2010 06:43 PM
power loss coop10 3.0 Vulcan Tech 2 03-06-2010 03:30 PM
2.5L power loss pepper809 4-Cylinder Tech 2 11-30-2009 09:12 PM
rough idle and loss of power eibbor697 3.0 Vulcan Tech 0 10-21-2009 12:27 PM
Loss of power califjeff 4-Cylinder Tech 5 08-28-2009 08:51 PM