Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-15-2013, 10:23 PM
PreRunner4.0 PreRunner4.0 is offline
Like the Forums
 
Join Date: Feb 2013
Posts: 37
Default 99 4.0 random popping/loss of power under acceleration

Well getting some miles my 99 Ranger I've found an annoyance. Sporadicly(maybe 4 times in the past three weeks) I'll be accelerating around 45-50 and the engine will start popping through the exhaust and it'll loose power, then it will randomly gain full power again....maybe after 10 seconds sometimes without letting off the gas to full blown feather the pedal, throw it in neutral and rev, drop back into gear and it'll quit doing it. No coolant in the oil, no white smoke out of the exhaust. Starts right up and idles smooth. No rhyme or reason when it acts up. Did it clmbing a hill and just cruising at 55 down the highway straightaway . Ideas?
__________________
99 Ranger XLT 4.0 auto
4" lift, 265x75x16 Cooper Discoverer AT3s
Skid plate, Pre runner Front fenders, welded diff
Reply With Quote
  #2  
Old 03-15-2013, 10:30 PM
Tito Tito is offline
Ford Motor Company
 
Join Date: Jul 2011
Posts: 125
Default

No engine light?

----------

Well start with basics when is last time u did tune up?
__________________
1990 ford ranger 2.3L
1999 Ford Ranger 2.5l

God bless!
Reply With Quote
  #3  
Old 03-15-2013, 10:34 PM
PreRunner4.0 PreRunner4.0 is offline
Like the Forums
 
Join Date: Feb 2013
Posts: 37
Default Re: 99 4.0 random popping/loss of power under acceleration

Quote:
Originally Posted by Tito View Post
No engine light?

----------

Well start with basics when is last time u did tune up?
Engine light. Don't have a code reader. Was going to give it a tune up, it was sitting for four years(at least that's what the 08 inspection sticker that was on it would lead me to believe)...but I didn't want to spend the money and have it not fix the problem. Also i be found I really have to stomp on the pedal to get full throttle...cable stretched possibly?
__________________
99 Ranger XLT 4.0 auto
4" lift, 265x75x16 Cooper Discoverer AT3s
Skid plate, Pre runner Front fenders, welded diff
Reply With Quote
  #4  
Old 03-15-2013, 10:43 PM
Tito Tito is offline
Ford Motor Company
 
Join Date: Jul 2011
Posts: 125
Default

Sitting for four years? Did u clean out old gas from tank and lines before starting it? Bad gas acts like glue on your valves.

----------

Cable usually stretch an easy fix for that would be putting zipties at end of cable at pedal . Anyways if it was sitting for so long i would change all fluids and tune up. Also take it to parts store and They will tell u codes no charge...

----------

Or did you at least put fuel stabalizer?
__________________
1990 ford ranger 2.3L
1999 Ford Ranger 2.5l

God bless!
Reply With Quote
  #5  
Old 03-15-2013, 10:44 PM
PreRunner4.0 PreRunner4.0 is offline
Like the Forums
 
Join Date: Feb 2013
Posts: 37
Default Re: 99 4.0 random popping/loss of power under acceleration

Quote:
Originally Posted by Tito View Post
Sitting for four years? Did u clean out old gas from tank and lines before starting it? Bad gas acts like glue on your valves.
Nope...it was on an eighth of a tank when I bought it, filled it to 3/4 to drive 40 miles home at 60 MPH and didn't have a single problem. But now that you brought it to my attention I wonder if I got bad gas when I filled up at sheets...it started after that even though I've run about 18 more gallons through it since then. Thinking about picking up plugs and sea foam tomorrow to start.
And I already changed the oil and the transmission filter.
__________________
99 Ranger XLT 4.0 auto
4" lift, 265x75x16 Cooper Discoverer AT3s
Skid plate, Pre runner Front fenders, welded diff
Reply With Quote
  #6  
Old 03-15-2013, 10:48 PM
Tito Tito is offline
Ford Motor Company
 
Join Date: Jul 2011
Posts: 125
Default

Yea start with that u definitly need that and since ur going to parts store stop by autozone/oreillys and ask them to pull your engine codes.
__________________
1990 ford ranger 2.3L
1999 Ford Ranger 2.5l

God bless!
Reply With Quote
  #7  
Old 03-15-2013, 10:50 PM
PreRunner4.0 PreRunner4.0 is offline
Like the Forums
 
Join Date: Feb 2013
Posts: 37
Default Re: 99 4.0 random popping/loss of power under acceleration

Quote:
Originally Posted by Tito View Post
Yea start with that u definitly need that and since ur going to parts store stop by autozone/oreillys and ask them to pull your engine codes.
Alright thanks man, I'll update what I find
__________________
99 Ranger XLT 4.0 auto
4" lift, 265x75x16 Cooper Discoverer AT3s
Skid plate, Pre runner Front fenders, welded diff
Reply With Quote
  #8  
Old 03-15-2013, 10:56 PM
Tito Tito is offline
Ford Motor Company
 
Join Date: Jul 2011
Posts: 125
Default

Yea bad gas especially after 6months let alone 4 years is plain varnish and if u did start it with that gasoline u ran it through ur fuel pump,lines, filter, injector, valves..etc it can cause complete engine failures. I gess you got lucky on that one.

----------

Alright man good luck. Pce
__________________
1990 ford ranger 2.3L
1999 Ford Ranger 2.5l

God bless!
Reply With Quote
  #9  
Old 03-15-2013, 10:59 PM
PreRunner4.0 PreRunner4.0 is offline
Like the Forums
 
Join Date: Feb 2013
Posts: 37
Default Re: 99 4.0 random popping/loss of power under acceleration

Quote:
Originally Posted by Tito View Post
Yea bad gas especially after 6months let alone 4 years is plain varnish and if u did start it with that gasoline u ran it through ur fuel pump,lines, filter, injector, valves..etc it can cause complete engine failures. I gess you got lucky on that one.
I mean I don't think it sat completly unused for 4 years but iy wasn't road legal or driven legally any kind of distance. Tires weren't flat spotted and all the brake lines were still silver but still who knows how long it sat before I picked it up.
__________________
99 Ranger XLT 4.0 auto
4" lift, 265x75x16 Cooper Discoverer AT3s
Skid plate, Pre runner Front fenders, welded diff
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle, hesitation on acceleration, loss of power tchachee 4.0 SOHC / 4.0 OHV Tech 18 04-09-2013 11:12 PM
Noise under full throttle acceleration, loss of power, flashing check engine light 03_Silver_Ranger 3.0 Vulcan Tech 2 11-29-2012 12:10 PM
Random loss of resistance in clutch pedal. Bad quick connect fitting? robwigglezz Drivetrain Tech 0 11-05-2012 05:52 PM
99 V6 no power, popping through intake? john 99 3.0 Vulcan Tech 8 05-23-2012 06:57 AM
Power Steering Popping medeirosnich Suspension Tech 1 09-28-2010 02:55 PM