Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2010, 08:12 AM
1freaky1 1freaky1 is offline
Just crazy enough!
 
Join Date: May 2009
Posts: 119
Send a message via Yahoo to 1freaky1
Default CEL keeps coming on

This is getting irritating to no end to say the least. I have cleaned the MAF sensor and all 3 O2 sensors and still the light is coming on after clearing the codes and driving less than a mile. I do not have an updated scanner to check it for more possible things that could be causing this so does anyone have some ideas? My scanner goes to 1998 and the current ranger is 2002 4.0, 5 speed 4x4.
To have it scanned at a shop here in town is upwards of $100+.
Reply With Quote
  #2  
Old 02-22-2010, 08:30 AM
2001xlt4d 2001xlt4d is offline
habba babba, Bartle doo?
 
Join Date: Aug 2009
Posts: 1,074
Send a message via AIM to 2001xlt4d Send a message via Yahoo to 2001xlt4d Send a message via Skype™ to 2001xlt4d
Default

take it to az and they will scan it for free
__________________
2001 ford ranger XLT/4.0 sohc./160,000
Mods:Cb/recon third brake light/air silencer mod/new door speakers and h/u / shorty console, 245-75-16 goodyear wrangler duratracs on rock crawler rims. hellas and 03 honeycomb grille.

Quote:
Originally Posted by surfer03133 View Post
ya, it can get tough to get the tool to fit in the slot,
Quote:
Originally Posted by 2004xlmiller View Post
drilling? id prefer not to drill down there.
EDGEMAN4.0 FOR PRESIDENT!!!!!!
Reply With Quote
  #3  
Old 02-23-2010, 04:39 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by 1freaky1 View Post
This is getting irritating to no end to say the least. I have cleaned the MAF sensor and all 3 O2 sensors and still the light is coming on after clearing the codes and driving less than a mile. I do not have an updated scanner to check it for more possible things that could be causing this so does anyone have some ideas? My scanner goes to 1998 and the current ranger is 2002 4.0, 5 speed 4x4.
To have it scanned at a shop here in town is upwards of $100+.
I am a little confused.have your tried your "old" scanner even if your scanner is old I think it should still work on the basics codes for your truck. every car 96+ has an obd-II port.You can buy a code reader for $35. as the other post said the auto parts store will read the codes for free. post them here and we can help. come back with the exact codes. don't come back and say my o2 sensor is bad!
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 02-23-2010, 05:02 AM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default

quit throwing parts at it, youre wasting youre money, go to autozone and get it scanned and go from there.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #5  
Old 02-23-2010, 06:54 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

Could be the pesky DPFE...get the code read.
Reply With Quote
  #6  
Old 02-23-2010, 07:45 AM
1freaky1 1freaky1 is offline
Just crazy enough!
 
Join Date: May 2009
Posts: 119
Send a message via Yahoo to 1freaky1
Default

Thanks guys I did not know autozone did that for free, I will see where one is around here, also will try my old scanner just to see if it will do anything. I did the old code clearing by disconnecting the battery to erase the code, should have said that earlier.

Patrick, I have not put in any new parts as of yet I do not like wasting money for parts that don't need replacing.

Last edited by 1freaky1; 02-23-2010 at 07:48 AM.
Reply With Quote
  #7  
Old 02-23-2010, 07:57 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by 1freaky1 View Post

Patrick, I have not put in any new parts as of yet I do not like wasting money for parts that don't need replacing.
I noticed Patrick's comment also! I was just going to let that slide I figured Patrick was not fully awake yet.

if your old scanner is in working order it should give you something when you read the codes.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #8  
Old 02-23-2010, 08:08 AM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default

Quote:
Originally Posted by 1freaky1 View Post
Thanks guys I did not know autozone did that for free, I will see where one is around here, also will try my old scanner just to see if it will do anything. I did the old code clearing by disconnecting the battery to erase the code, should have said that earlier.

Patrick, I have not put in any new parts as of yet I do not like wasting money for parts that don't need replacing.
yeah sorry man, i misread your post. it was early, my bad.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #9  
Old 02-23-2010, 08:22 AM
2001xlt4d 2001xlt4d is offline
habba babba, Bartle doo?
 
Join Date: Aug 2009
Posts: 1,074
Send a message via AIM to 2001xlt4d Send a message via Yahoo to 2001xlt4d Send a message via Skype™ to 2001xlt4d
Default

Quote:
Originally Posted by 01_ranger_4x4 View Post
yeah sorry man, i misread your post. it was early, my bad.

Dam patrick... wake up next time!
__________________
2001 ford ranger XLT/4.0 sohc./160,000
Mods:Cb/recon third brake light/air silencer mod/new door speakers and h/u / shorty console, 245-75-16 goodyear wrangler duratracs on rock crawler rims. hellas and 03 honeycomb grille.

Quote:
Originally Posted by surfer03133 View Post
ya, it can get tough to get the tool to fit in the slot,
Quote:
Originally Posted by 2004xlmiller View Post
drilling? id prefer not to drill down there.
EDGEMAN4.0 FOR PRESIDENT!!!!!!
Reply With Quote
  #10  
Old 02-24-2010, 07:40 AM
1freaky1 1freaky1 is offline
Just crazy enough!
 
Join Date: May 2009
Posts: 119
Send a message via Yahoo to 1freaky1
Default

No Problemo there Patrick, I know how it is when its early.

Thanks for the suggestion on the scanner reading all OBD-IIs so hooked it up yesterday and here is where it stands now.

I did find out that the scanner I have will read all Ford OBD-IIs up to 2002 which was a big relief. I did find it interesting that one of the O2 sensors voltage was not fluctuating like the other two O2 sensors until I goosed the pedal, then it starting working.
I do not get why the Rangers use 3 O2 sensors and need to find out which one is where as far as Bank 1 & 2 sensor 1,2,3 for each bank.

There are no codes and the light has not came back on since I cleared the codes earlier, after driving around yesterday several close to home trips everything seems to be ok, but I am keeping my scanner hooked up so if and when the CEL comes back on I can scan it right away.
While looking thru the data info there were 4 things it said failed and I'm thinking that these are items on the capture mode that did not run fully before I turned the scanner off. will need to find my book for the scanner and computer codes.

Also if anyone needs some info on the OBD-II ranges (parameters) check this page out;

http://en.wikipedia.org/wiki/OBD-II_PIDs#Standard_PIDs
Reply With Quote
  #11  
Old 02-24-2010, 08:05 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Do you know what the original codes you had were( the Actual # ie, P0000). Bank 1 is passenger side, Bank 2 is drivers side. Sensor 1 is precat sensor 2 is after cat. I don't know the setup on your truck if you have a Y pipe or not someone else will know. for the most part the precat sensor are the ones the effect engine management. get us some codes and we can probably figure it out for you.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #12  
Old 02-24-2010, 08:11 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I am going to guess that one of the codes you get/got is either p0133 or p0153
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #13  
Old 02-24-2010, 09:37 AM
Ticker Ticker is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 4
Default Let me know

Let me know what you find out after the scan. Very interested.



Quote:
Originally Posted by 1freaky1 View Post
This is getting irritating to no end to say the least. I have cleaned the MAF sensor and all 3 O2 sensors and still the light is coming on after clearing the codes and driving less than a mile. I do not have an updated scanner to check it for more possible things that could be causing this so does anyone have some ideas? My scanner goes to 1998 and the current ranger is 2002 4.0, 5 speed 4x4.
To have it scanned at a shop here in town is upwards of $100+.
__________________
2000 Ranger XL Regular Cab 3.0 flex 4R44E Automatic trans.
Reply With Quote
  #14  
Old 02-25-2010, 10:07 AM
1freaky1 1freaky1 is offline
Just crazy enough!
 
Join Date: May 2009
Posts: 119
Send a message via Yahoo to 1freaky1
Default

Quote:
Originally Posted by modelageek View Post
Do you know what the original codes you had were( the Actual # ie, P0000). Bank 1 is passenger side, Bank 2 is drivers side. Sensor 1 is precat sensor 2 is after cat. I don't know the setup on your truck if you have a Y pipe or not someone else will know. for the most part the precat sensor are the ones the effect engine management. get us some codes and we can probably figure it out for you.
Thanks for the input as far as which bank is which cause I was thinking it was the opposite. , We had disconnected the battery before I found out that my scanner would work on it, so now I am waiting to see if the CEL comes on again and will right down the codes so I can post it up here.
Reply With Quote
  #15  
Old 02-25-2010, 10:13 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I would check the codes even if the cel is off. The codes somtimes are pending but they can go away without the cel coming on. Check them especially when the truck is acting up
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noises coming from my motor mudslut77 4.0 SOHC / 4.0 OHV Tech 4 05-15-2011 08:46 AM
Look what's coming my way! dixie_boysles Off Topic 17 01-31-2010 02:52 PM
Changes are coming... Lazler Vehicle Snapshots 20 01-30-2010 12:12 PM
Black Friday coming up! usmcwpntech Money Saving Deals 26 11-28-2009 12:56 AM
Another coming from RF enraged_hunter Introduce Yourself 16 09-26-2009 11:47 AM