Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-23-2013, 10:28 AM
groelzj groelzj is offline
Learning to use the forums
Join Date: Oct 2012
Posts: 6
Default No fuel, 12v at Inertia switch, not sure if pump is running

Ok, here's the skinny: It's my Fiancee's truck, it overheated and was cheaper to do an engine swap than redo the intake manifold gasket. New thermostat fixed the overheating source (she was just checking the overflow, not the radiator.)

It's a 2004 Ford Ranger XLT 4.0L SOHC, 4x4, manual transmission.

Swapped in a 4.0L SOHC engine out of a 2004 Explorer with Automatic tranny.

Engine turns over with the key, but no ignition. I have spark, air, compression, but I have zero pressure in my fuel pressure gauge at the Fuel Rail and at the Fuel Pressure Regulator.

The Fuel Pump Relay works fine, clicks in for 2 seconds when I turn the key on, even tried swapping the A/C relay, same result, the fuel pump fuse is good, I have 12v at the inertia switch and when I checked continuity at the switch it cuts out with impact and restores with reset button. I've tried jumping the connector with a paperclip to take the inertia switch out of the equation and it makes no difference.

I hear what I assume to be a high pressure fuel pump kick on for about 2 seconds when I turn the key, but I don't hear it from the fuel tank, it's under the driver's seat along the frame. (I'm doing the repair alone and just unhooked the pos. terminal of the battery and used jumper cables to complete the circuit so I could hear whether the pump was kicking on by leaving the key on, and touching/separating the jumper cable leads.)

I still have zero pressure in the fuel rail...

Two years ago she had the fuel tank sending unit replaced and it didn't fix the fuel gauge problem...after the mechanic replaced it, he traced it down to melted wiring in the wiring loom near the firewall (I don't remember exactly where anymore...)

The check engine light comes on when I turn the ignition to 'on'.

The small ground wire to frame from the battery is hooked up, as is the ground from the back of the head to the firewall next to the wiper motor on the driver's side. I don't remember removing any other ground wires when I swapped the engines, but I know the computers can be finicky without proper solid grounding.

None of the fuel lines that I can see in the engine bay are crushed/pinched/bent to stop fuel there a schrader valve on the fuel line closer to the tank, or just up in the engine bay? (on the fender well and on the fuel rail)

The engine has ignition with a poof of starter fluid, but I don't want to use more than a poof, especially if it's not getting gas.

I have spark, compression, and air, but I am not getting fuel.

I think my next step is to try to disconnect the fuel pump wire clip and see if I get 12v there. If not, I expect my fuel pump just went out on my coincidentally while I was changing the engine...but I wondered if there was anything else I should check before I become a contortionist/expand my cursing vocabulary/drop the fuel tank/remove the bed.

The Explorer engine was grounded through a strap on the passenger side of the head, but I used the Ranger strap and location instead...the Explorer one had been cut in half when the junkyard pulled it. I treated it as a long block and swapped all external components over from the Ranger. Some of the sensors had the same connectors, so I left them for now, but it fires for a couple revs on a spray of starting fluid, so I'm sure the sensors are fine, I'm not aware of a sensor between the inertia switch and the fuel pump, let alone one that would cut off voltage when the computer was sending 12v there for 2 seconds when I turn on the key.

I borrowed an inspection camera from work ($100 at Home Depot, thinking about getting one myself for that price!) to check for corrosion at the fuel pump connections, but the leads are inside a plastic clip. I'll try unplugging/reconnecting that clip tonight when I check for 12v there.

Where does the wire run after it leaves the inertia switch? I want to trace the wires, but it's hard when it's dark by the time I get home and I'm working by headlamp. I suspect when the mechanic spliced wires to get the fuel sending unit working, he may have spliced fuel pump power wires too, but I don't know where they run!

Sorry for the lengthy post, but I've done my research, and wanted to list what had been done up to this point. The mechanic at work said to soak a rag in gasoline and hold it in front of the intake hose at the air filter...that should get enough fumes to run the engine long enough to at least let me get trouble codes to see if I missed a sensor/have a loose connection somewhere.

I haven't swapped out the fuel filter, but that was done a couple hundred miles ago.

Any other places to check would be welcome suggestions at this point!

Reply With Quote
Old 01-24-2013, 07:01 PM
Rico98 Rico98 is offline
Learning to use the forums
Join Date: Feb 2011
Posts: 2
Default Re: No fuel, 12v at Inertia switch, not sure if pump is running

Just went through this with a '98 Supercab 4.0 4X4. Parked it one night, next morning, nothing. No fuel, cranked with no start. Was going to drop the tank, replace pump, filter. No improvement. Out of desparation, flat bed to mechanic, replaced crank angle sensor. Shazam! Good as new. If Crank sensor is bad, she pump won't pump. In fact, it wouldn't register on my scanner. So give the crank sensor a look. Worked for me. Good luck.
1998 Ranger XLT 4X4 Supercab
4.0 5 Speed.
Reply With Quote
Old 01-31-2013, 09:52 AM
groelzj groelzj is offline
Learning to use the forums
Join Date: Oct 2012
Posts: 6
Default Re: No fuel, 12v at Inertia switch, not sure if pump is running

I finally got back to the truck. The fuel pump doesn't work. I pulled it from the truck and tried connecting it directly to the battery of our other car and not even a click!

Good news is; Napa has a 1 year warranty on this pump and we still have the receipt from when we bought it 9 months ago! Wish me luck getting them to hand over another $330 pump assembly.
Reply With Quote

4.0 sohc, no fuel, no start, wiring location

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Pump Keeps Running. Welcome Any Advice!!! markford 2.9 Liter Tech 37 09-22-2013 10:43 AM
Fuel pump inertia switch issue fumanchueatyou Electrical Tech 5 05-16-2012 05:54 PM
Where is the fuel pump switch? chaseprenger 3.0 Vulcan Tech 3 07-20-2011 04:38 PM
no power to fuel pump or inertia switch 50mustangs 3.0 Vulcan Tech 8 03-27-2011 05:48 PM
Running issues. acts like fuel pump Jaedgar 4-Cylinder Tech 1 11-24-2010 08:36 AM