Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 11-25-2012, 08:52 AM
Ford Ranger Owner
 
Join Date: Sep 2012
Posts: 63
Default idle misfire gone when unplug MAF

so i have a misfire at idle and my mpg has dropped from about 17-18 to 14-15 for the last 2 tank fulls..when i unplug the mass air flow sensor it dissapears and idles smooth. tried driving like this but it shifted way too hard..

i have cleaned the MAF and checked for vacuum leaks but couldnt find any.. the smoke test did show that the idle air control and egr valve leak but from what i could find these are vented to the atmosphere.. i sprayed both with carb cleaner and even tried propane while the engine was running to detect a change in idle but turned up nothing..

going to check and see plug condition and do a compression test and see if that turns up anything..

anyone have any thoughts or experience with this situation? maybe theres a common problem im unaware of i should be checking out?
__________________
2003 Sonic Blue Ranger Edge Plus 4dr, FFV 3.slow v6, 2wd, Flowmaster, Kenwood 1800w amp 2-10" Xplod in Custom Enclosure
Reply With Quote
  #2  
Old 11-25-2012, 08:57 AM
Mr. One Fitty
 
Join Date: Apr 2011
Posts: 17,118
Send a message via AIM to djfllmn
Default Re: idle misfire gone when unplug MAF

what did you use to clean the MAF? im willing to bet the MAF is bad
__________________
2014 F150 Supercrew XLT 5.0(ALL the options)
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)
DD-1992 Olds Cutlass Ciera
traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 11-25-2012, 09:55 AM
Ford Tough
 
Join Date: Oct 2012
Posts: 260
Default Re: idle misfire gone when unplug MAF

i notice you have kn air filter, did you give it a fresh oil cleaning in the last while? if so you could have an oil film on/in the MAF.
__________________
Don't spend good money fixing phantom problems. Test, diagnose, and buy the right part(s) to fix the right problem. Read & learn here
http://www.aa1car.com/index_alphabetical.htm
http://easyautodiagnostics.com/main_...articles_1.php
check that sensor BEFORE replacing
http://www.aa1car.com/library/2002/cm70248.htm
Reply With Quote
  #4  
Old 11-25-2012, 03:47 PM
Ford Ranger Owner
 
Join Date: Sep 2012
Posts: 63
Default Re: idle misfire gone when unplug MAF

i used maf cleaner made by CNC and yes i just got the K&N filter about a month ago and oiled at that time.. the MAF looked like new but i cleaned it anway since then..

from my understanding even though the misfire goes away when i unplug the MAF, thats just showing that the MAF IS working and that the problem is somewhere else.. i would think its an air/fuel issue and not ignition because unplugging the MAF wouldnt effect an ignition issue and the misfire would still be there.. i think..

i get what sounds like a vacuum leak sometimes when at idle in gear once the car is warm but can not find it.. i have tried spraying every where with carb cleaner and did the smoke test but nothing.. maybe the sound of fluid running through a line somewhere sounds like a whistle? seems to be coming from under the truck near bell housing/engine area..

heres a video of the whistle.. around 30 sec is when you can hear it..
__________________
2003 Sonic Blue Ranger Edge Plus 4dr, FFV 3.slow v6, 2wd, Flowmaster, Kenwood 1800w amp 2-10" Xplod in Custom Enclosure
Reply With Quote
  #5  
Old 11-25-2012, 09:06 PM
Ford Tough
 
Join Date: Oct 2012
Posts: 260
Default Re: idle misfire gone when unplug MAF

i would like to know how you kept your motor running by unplugging the maf? i was trying this today and it would run for about 30 seconds then dies. i took off the plastic intake that goes to the throttle body to get more air in... still couldn't keep the engine running. mine is 90tm.
__________________
Don't spend good money fixing phantom problems. Test, diagnose, and buy the right part(s) to fix the right problem. Read & learn here
http://www.aa1car.com/index_alphabetical.htm
http://easyautodiagnostics.com/main_...articles_1.php
check that sensor BEFORE replacing
http://www.aa1car.com/library/2002/cm70248.htm
Reply With Quote
  #6  
Old 11-26-2012, 03:01 PM
Ford Ranger Owner
 
Join Date: Sep 2012
Posts: 63
Default Re: idle misfire gone when unplug MAF

i just unplugged the sensor where it connects to the air filter housing.. it idled fine and i drove it to the store but shifted harder than a mofo.. so bad i felt like the tranny was gona break so i plulled over and plugged it back in after about 1/2 mi of driving.. this is a 97 4.0 ohv
__________________
2003 Sonic Blue Ranger Edge Plus 4dr, FFV 3.slow v6, 2wd, Flowmaster, Kenwood 1800w amp 2-10" Xplod in Custom Enclosure
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
'99 Rough idle/Misfire 2.5L RobMD 4-Cylinder Tech 46 04-20-2013 07:22 AM
Rough idle/misfire Spoone 3.0 Vulcan Tech 16 07-29-2012 08:18 AM
rough idle and misfire code wgotsch2 3.0 Vulcan Tech 2 06-12-2012 01:03 PM
96 3.0 high idle, misfire on 2 & 5 nailbanger138 3.0 Vulcan Tech 1 03-22-2011 06:33 PM
no misfire, still rough idle!!! RangerLuc 4.0 SOHC / 4.0 OHV Tech 13 05-15-2010 04:49 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.