Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 09-30-2012, 06:48 PM
Learning to use the forums
 
Join Date: Sep 2012
Posts: 3
Question 94 Ranger 4.0 Idling/Starting Problem(s)

Hi I recently bought a 1994 Ford Ranger with the 4.0, 5speed, 4X4. When you start the truck it will idle up to about 2000-2500 rpm for a minute or so then it will idle down rough and surge up and down for a minute or so, then after that it will idle steady at about 1100 rpm and drives down the road with no significant problems. However, after it is warmed up and you shut it off, it turns over but doesn't want to start again until it has sat awhile (usually an hour or two). I have been able to get it to start like this by holding the pedal to the floor, I read somewhere on here that doing that tells the comp/fuel pump to send no fuel. It has a new idle air control valve and engine coolant temp sensor (the one for the computer). When it's warm and you turn it over it seems to get spark (I pulled a plug wire and saw spark) and it also seems to get fuel (I can hear the fuel pump kick in and smell the fuel-it smells like it's flooding out) I've also tried swapping the fuel pump and comp. relays when it does this and it doesn't do anything. The guy I bought it from rebuilt the manual transmission himself and sometime after (not sure when) he said the wires to the clutch switch (not sure what it's called, it's on the rod the clutch pedal is linked to) burnt off at the pin connector that clips to it. The two wires that burnt are pink and the other is red with blue I think. He told me that it never had the idle problem until those wires melted off. He also put a toggle switch in so you turn the ignition and then push the button to start it, I'm guessing he did this to bypass that clutch switch? Oh I also noticed when its went through its 3-4 minute startup routine and starts its steady idle at 1100 rpm that if you unplug either the MAF or the IAC that it will idle down to about 800 rpm where it sounds more like it should be idling. Check engine light comes on and I've tried scanning it but haven't had any luck. KOEO scan will take a long time and then say that it was unable to connect or that it's not responding and scanner says to check connections at DLC or something like that. When I try the scan with the engine running it's like the vehicle knows I'm trying to scan it and as soon as the check engine light comes on it will idle up or down and switch the light off so that it won't stay on long enough to pull any code. Does anyone have any ideas of what could be causing this problem or things I could try to fix this-I like the truck but I don't want to just throw any more money at it unless I'm more certain I can solve this problem. If anyone has any ideas please help, Thanks
__________________
1994 Ford Ranger SLT 4.0L 5spd 4X4 Extended Cab

Last edited by jlassonde88; 09-30-2012 at 08:20 PM.
Reply With Quote
  #2  
Old 10-02-2012, 07:33 PM
Learning to use the forums
 
Join Date: Sep 2012
Posts: 3
Default Re: 94 Ranger 4.0 Idling/Starting Problem(s)

Does anyone have any ideas? I was wondering if it could be the clutch switch or ignition? Or would it more likely be the computer itself? Does anybody know any tests I could try for like comp. or similar things, to see if they are working?
__________________
1994 Ford Ranger SLT 4.0L 5spd 4X4 Extended Cab
Reply With Quote
  #3  
Old 01-20-2013, 10:52 AM
Learning to use the forums
 
Join Date: Sep 2012
Posts: 3
Question Re: 94 Ranger 4.0 Idling/Starting Problem(s)

Still haven't solved the problem... Haven't tried anything new yet. Would like to use the truck to haul wood, anyone know where would be a good place to start on solving this problem?
__________________
1994 Ford Ranger SLT 4.0L 5spd 4X4 Extended Cab
Reply With Quote
  #4  
Old 01-20-2013, 05:52 PM
Learning to use the forums
 
Join Date: Jan 2013
Posts: 3
Default Re: 94 Ranger 4.0 Idling/Starting Problem(s)

I had some big idle issues on my 97 4.0 ranger 4x4. I ended up replacing the gaskets on the plenum as well as the gasket that goes between the fuel rail and top of the intake manifold. Now the truck idles perfect. One thing you can try to see if you are suffering from a vacuum leak as I was; take some carb cleaner and spray it around your engine. If the idle changes you may have a vacuum leak. Before I did this my truck would hunt for idle when cold, when it was warm it would run great going down the road, but the idle surged , and a lot of times the truck would stall when I didn't have my foot on the gas.
Reply With Quote
Reply

Tags
computer, electrical, idle, problem, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem on 94 Ranger sclem General Tech 2 09-22-2011 03:34 PM
ranger problem starting jerry101 General Ford Ranger Discussion 0 08-08-2011 07:01 PM
Idling problem ranger2002 Electrical Tech 1 12-02-2010 03:19 PM
94 ranger starting problem? bvad 4.0 SOHC / 4.0 OHV Tech 3 08-20-2010 04:18 PM
2007 3.0L starting & idling issue bigblock 3.0 Vulcan Tech 17 03-17-2010 06:52 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.