Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 08-13-2012, 11:12 AM
Learning to use the forums
 
Join Date: Aug 2012
Posts: 5
Post 2000 Ford Ranger - P1151, P1152, P0306, P0175

Just the other day my 2000 4.0L Ranger XLT started running rough, I have pulled the codes and have got :

P1151
P1152 - Pending
P0306
P0175

when I tested it at first the code P0306 never showed up, it showed up after I cleared out the original codes.

my Freeze frame information is as follows :

DTCFRZF ----- P0306
Fuelsys1 ------CL
FuelSys2------N/A
Load %-------80.4
ETC (degres C) 93
Shrtft1 (%)---- 1.6
Longft1(%)---- -0.8
Shrtft2 (%)--- 42.2
Longft2 (%)---- -2.3
RPM (/min) ---- 1686
VSS (km/h) 84


My symptoms are bucking and jarring under any load, and significant loss of power, I thought it may have been my downward O2 Sensor but I changed that out and it was fine, I took out my #6 plug and that did nothing. I checked my MAFS and it is fine as well. Any help would be greatly appreciated.
__________________
Ranger Danger! 255,000KM
Reply With Quote
  #2  
Old 08-13-2012, 05:52 PM
Liking the Ford Ranger Forum
 
Join Date: Aug 2012
Posts: 24
Default

Man I have the SAME stuff but I've kinda gotten rid of it I'll turn off my truck when in starts and turn it back on, but also I have had my motor replaced, and I had all the same symptoms with it too and they came back ive rand new wires, spark plugs, and on my 3rd coil pack and my trucks a '99 so it's the same model as stuff as yours.
__________________
1999 Ford Ranger Blacked out blinkers, tail lights, third brake light, Limo tint
31"x10.50"r15 cooper ats, 3" fabtech spindle lift
2000 watt monoblock amp 2 12" square mb quart subs JVC headunit, 800 watt 4 channel amp
Reply With Quote
  #3  
Old 08-13-2012, 07:36 PM
If it works,don't fix it!
 
Join Date: Dec 2011
Posts: 966
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by sniper69714 View Post
Just the other day my 2000 4.0L Ranger XLT started running rough, I have pulled the codes and have got :

P1151
P1152 - Pending
P0306
P0175

when I tested it at first the code P0306 never showed up, it showed up after I cleared out the original codes.

my Freeze frame information is as follows :

DTCFRZF ----- P0306
Fuelsys1 ------CL
FuelSys2------N/A
Load %-------80.4
ETC (degres C) 93
Shrtft1 (%)---- 1.6
Longft1(%)---- -0.8
Shrtft2 (%)--- 42.2
Longft2 (%)---- -2.3
RPM (/min) ---- 1686
VSS (km/h) 84


My symptoms are bucking and jarring under any load, and significant loss of power, I thought it may have been my downward O2 Sensor but I changed that out and it was fine, I took out my #6 plug and that did nothing. I checked my MAFS and it is fine as well. Any help would be greatly appreciated.
By the looks of your freeze frame on fuel trims ,both long and short for bank 2, I would say that the O2sensor is dead. Your full on rich.
If your scanner will give live data, you can see what your down steam O2 sensor is doing too. The down steam sensor is more of a Catalyst monitor than a O2 sensor though.
__________________
2011 Ranger XLT 2x4,4.0 SOHC, 5 Speed Auto, 3.55 Rear. Oxford White.

Simplicity is the ultimate sophistication.

Torque it down till it breaks off, then back it off 1/4 turn.
Reply With Quote
  #4  
Old 08-14-2012, 07:15 AM
Liking the Ford Ranger Forum
 
Join Date: Aug 2012
Posts: 24
Default

Yeah I've replaced my O2 sensors and it did nothing, they said its probably my cats but them jokers are way to expensive to buy because it "might" be the problem
__________________
1999 Ford Ranger Blacked out blinkers, tail lights, third brake light, Limo tint
31"x10.50"r15 cooper ats, 3" fabtech spindle lift
2000 watt monoblock amp 2 12" square mb quart subs JVC headunit, 800 watt 4 channel amp
Reply With Quote
  #5  
Old 08-15-2012, 09:06 AM
Learning to use the forums
 
Join Date: Aug 2012
Posts: 5
Exclamation Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Hey Guys,

Thanks for all your help, I replaced all my plugs last night and I got rid of the miss fire code, and now I just have the "rich bank 2 code" I have checked my vacuum lines, replaced my #2 O2 sensor. I was going to check my compression in cylinder 6 this weekend but I won't have time. I have checked the compression a few times in the past and it all seems to be fine, I have had a similar problem to this before but a simple change of the plugs worked last time.

Does anyone know a way to check an O2 sensor??
__________________
Ranger Danger! 255,000KM
Reply With Quote
  #6  
Old 08-21-2012, 08:59 PM
Firefighter
 
Join Date: Aug 2012
Posts: 22
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by sniper69714 View Post
Hey Guys,

Thanks for all your help, I replaced all my plugs last night and I got rid of the miss fire code, and now I just have the "rich bank 2 code" I have checked my vacuum lines, replaced my #2 O2 sensor. I was going to check my compression in cylinder 6 this weekend but I won't have time. I have checked the compression a few times in the past and it all seems to be fine, I have had a similar problem to this before but a simple change of the plugs worked last time.

Does anyone know a way to check an O2 sensor??

Were you able to get rid of the missfires?
__________________
I have 3 speeds, fast, faster and long gone!

1998 Splash 4.0 OHV 5 speed
Reply With Quote
  #7  
Old 08-21-2012, 09:23 PM
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,403
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

there really isnt a way, id just but a new one. relatively cheap.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #8  
Old 08-22-2012, 04:29 AM
Firefighter
 
Join Date: Aug 2012
Posts: 22
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by sniper69714 View Post

My symptoms are bucking and jarring under any load, and significant loss of power, I thought it may have been my downward O2 Sensor but I changed that out and it was fine, I took out my #6 plug and that did nothing. I checked my MAFS and it is fine as well. Any help would be greatly appreciated.
These are my EXACT issues. Any little hill and it starts bucking and smells like sulfer from exhaust. Major lack of power and hesitation that comes and goes. What did you do to fix the issue OP Sniper? I am $500 deep into new parts and cannot identify the issue.
See this post: Help
__________________
I have 3 speeds, fast, faster and long gone!

1998 Splash 4.0 OHV 5 speed

Last edited by Wisconsinz; 08-22-2012 at 04:32 AM. Reason: clarity
Reply With Quote
  #9  
Old 08-22-2012, 07:30 AM
03 2.3 Ford Ranger 2wd
 
Join Date: Jun 2012
Posts: 369
Send a message via MSN to jcube_04 Send a message via Yahoo to jcube_04
Default

Smell of sulfur = plugged catalytic converter
__________________
Jeremy Block
2003 Ranger 2wd 5 spd. 2.3L, 3 in blocks, 5 in. Camburg spindles, 1 in uniball upper control arms, upgraded coils with Rancho shocks. Buggman LED cluster. Painted 2wd fog bezel, shifter cupholders, door handle surrounds, window lever, and lock lever. 33 in wild countrys.
Reply With Quote
  #10  
Old 08-22-2012, 11:17 AM
Firefighter
 
Join Date: Aug 2012
Posts: 22
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by jcube_04 View Post
Smell of sulfur = plugged catalytic converter
If it were so simple. Cats are good, I disconnected them and drove it, still hesitated and was super loud. Bad cat smell is from unburned raw fuel dumping into the cats.

Mechanic this morning hooked up a snap-on ODBII scan tool. Like a mini PC with a touchscreen.

2 codes were present in the Engine section.

P sum-thing o2 sensor 1 is Rich
P sum-thing 02 sensor 2 is Lean
o2s21 5-6 mv
o2s22 1-3 mv
MAF (v) 0.02 volts

He set the scanner to read live data and determined that Cylinder 1 was missing intermittently and cylinder 6 would miss every 20 seconds or so randomly. I swapped plug wires with cyl 1 and 2 no change

o2 voltage was present and seemed to be working fine (both sensors are under a year old)

Come on guys, help me out. A car payment (2010 or newer) and no headache sounds good right now but I can't give up yet

----------

Edit:

also the SFTRIM 2(%) was at 14%
and the LFTRIM 2(%) was at 0%

Does any of this help?

My mechanic says either new sending unit ($200) or a set on injectors ($alot) unless I have any other ideas.

I cannot keep throwing money at it like a hot stripper here.

HELP!
__________________
I have 3 speeds, fast, faster and long gone!

1998 Splash 4.0 OHV 5 speed
Reply With Quote
  #11  
Old 08-22-2012, 01:24 PM
03 2.3 Ford Ranger 2wd
 
Join Date: Jun 2012
Posts: 369
Send a message via MSN to jcube_04 Send a message via Yahoo to jcube_04
Default

Try swapping plugs. a bad cylinder with a known good one and do the same with the injectors just dont swap one from the same good cylinder as the spark plug swap. Does that make sense?
__________________
Jeremy Block
2003 Ranger 2wd 5 spd. 2.3L, 3 in blocks, 5 in. Camburg spindles, 1 in uniball upper control arms, upgraded coils with Rancho shocks. Buggman LED cluster. Painted 2wd fog bezel, shifter cupholders, door handle surrounds, window lever, and lock lever. 33 in wild countrys.
Reply With Quote
  #12  
Old 08-24-2012, 11:50 AM
03 2.3 Ford Ranger 2wd
 
Join Date: Jun 2012
Posts: 369
Send a message via MSN to jcube_04 Send a message via Yahoo to jcube_04
Default

Ive also seen this in a failing coil. Have you tried my previous suggestion yet?
__________________
Jeremy Block
2003 Ranger 2wd 5 spd. 2.3L, 3 in blocks, 5 in. Camburg spindles, 1 in uniball upper control arms, upgraded coils with Rancho shocks. Buggman LED cluster. Painted 2wd fog bezel, shifter cupholders, door handle surrounds, window lever, and lock lever. 33 in wild countrys.
Reply With Quote
  #13  
Old 08-24-2012, 02:07 PM
Firefighter
 
Join Date: Aug 2012
Posts: 22
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by jcube_04 View Post
Ive also seen this in a failing coil. Have you tried my previous suggestion yet?
I tried everything I can think of and am really ready to fix it or nix it.

I swapped plugs with good Cylinders. Miss seemed to go away until I went up a small hill and it was back to dog'n again and consuming double the gas it should. Hooked up a gauge to fuel rail nipple. Book says between 58 and 72 psi. It has 62 at Idle and 60 psi at 3500 RPM, no big drop while pegginh the gas pedal..
It is getting gas, air and spark. Why the intermittent mis-fire on cyl 1 and 6?
New coil and plugs and wires already sit in the money pit. I also have the original coil that came with the truck.(tests good)

TPS is due in Monday but I do not think it will help.

ANY IDEAS here guys?
__________________
I have 3 speeds, fast, faster and long gone!

1998 Splash 4.0 OHV 5 speed
Reply With Quote
  #14  
Old 08-24-2012, 07:47 PM
03 2.3 Ford Ranger 2wd
 
Join Date: Jun 2012
Posts: 369
Send a message via MSN to jcube_04 Send a message via Yahoo to jcube_04
Default

One last ghing brgore im out of ideas. starg hour truck and let it run for a minute. Then shut it off and pull the hose of the vacuum brake booster to see if there is vacuum pressure
__________________
Jeremy Block
2003 Ranger 2wd 5 spd. 2.3L, 3 in blocks, 5 in. Camburg spindles, 1 in uniball upper control arms, upgraded coils with Rancho shocks. Buggman LED cluster. Painted 2wd fog bezel, shifter cupholders, door handle surrounds, window lever, and lock lever. 33 in wild countrys.
Reply With Quote
  #15  
Old 08-25-2012, 08:11 PM
Firefighter
 
Join Date: Aug 2012
Posts: 22
Default Re: 2000 Ford Ranger - P1151, P1152, P0306, P0175

Quote:
Originally Posted by jcube_04 View Post
One last ghing brgore im out of ideas. starg hour truck and let it run for a minute. Then shut it off and pull the hose of the vacuum brake booster to see if there is vacuum pressure
I will try that tomorrow when it's light out. What will that prove or disprove? I just may make a video of it idling. It has a weird sucking / hissing noise when you give it gas, much like a vac leak. Cannot find it anywhere.
__________________
I have 3 speeds, fast, faster and long gone!

1998 Splash 4.0 OHV 5 speed
Reply With Quote
Reply

Tags
4.0l sohc, cylinder misfire, p0306, p1151, p1152

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
P1151 and P1451 dbshocker 4.0 SOHC / 4.0 OHV Tech 4 04-27-2012 08:58 AM
2000 Ford Ranger Thodge Introduce Yourself 5 02-02-2012 01:51 AM
Need help with codes P1132 P1152 P0172 P0175 MAILMAN 3.0 Vulcan Tech 13 10-08-2011 07:35 AM
2000 ford ranger Lilpowerranger Introduce Yourself 5 05-15-2009 02:31 PM
ford ranger 2000..............? Tony J General Ford Ranger Discussion 2 12-28-2008 01:40 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.