Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-08-2010, 11:28 PM
SpitfireEMT SpitfireEMT is offline
Muddy, as usual
 
Join Date: Oct 2009
Posts: 386
Send a message via MSN to SpitfireEMT
Default MAF troubles

So my maf is shot. Cleaned it real good, and it held up for 2 days and the CEL came back on. Went to autozoo and they wanted around $100 for a new one, but it has the housing. the housing is fine, is there a way I can just buy the sensor? Havent had much luck so far. Any thoughts?
__________________
2000 XLT 4x4, 4dr ext cab, 4.0L OHV, 4.10 LSD
265/75/16 Goodyear Duratracs
Mountaineer seats, Expo OHC
2003 EDGE front clip conversion
133rwhp/192rwtq-->6-28-11

1969 Mercury Cougar
351W, FMX, 3:1 open diff in a Ford 9"
Undergoing restoration
Reply With Quote
  #2  
Old 01-09-2010, 07:38 AM
mcpink mcpink is offline
Infidel
 
Join Date: Nov 2009
Posts: 1,771
Default

Find one at a jy maybe?
__________________
02 Ranger XLT 4x4 Off Road, 4.0L SOHC, Automatic, 8.8 4.10 LS, Super-Cab, 3" Body Lift, 33x12.5x15 BFG All Terrains on 15x8 M/T Classic IIs, 5K 55w Heads, 5K 35w fogs, custom front skid plate, various other goodies.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Window Troubles pmac General Ford Ranger Discussion 14 08-06-2011 03:55 PM
Tranny Troubles cspeir Drivetrain Tech 8 07-10-2009 09:13 AM