Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-22-2012, 05:19 AM
crazymays77 crazymays77 is offline
Ford Truck Driver
 
Join Date: Dec 2011
Posts: 98
Default spitting and sputtering

Ok last night I stopped at a stop sign and when I took off it had no power just spit and sputtered. Did it for a min maybe then right back to normal. Anyone know what it was?
__________________
99 ford ranger xlt stepside 4.0l 4x4 auto.
Reply With Quote
  #2  
Old 03-29-2012, 02:03 PM
03 xlt 03 xlt is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 6
Default Re: spitting and sputtering

Check your MAF sensor try cleaning it or replacing it
Reply With Quote
  #3  
Old 04-04-2012, 08:38 PM
joekap joekap is offline
Learning to use the forums
 
Join Date: Nov 2011
Posts: 11
Default Re: spitting and sputtering

Also could be a sign that your cam shaft positioning sensor is going. If it is, it should throw an obd code 0320 i think.
Reply With Quote
  #4  
Old 04-06-2012, 06:57 AM
slavedeath slavedeath is offline
Learning to use the forums
 
Join Date: Apr 2012
Posts: 2
Default

On the top of you engine is a piece that looks like a sliver soda bottle, its a throttle/idle speed control valve? Anyway pull that off and inside is a valve clean that out real good or replace it your choice. I had the same problem a few months ago and what happens is that valve helps regulate who much air flow your throttle gets. Sometime it gets gummed up and cant open back up at slow or idle speeds and it chokes off the engine. Give that a try and see uf that fixes the problem. If you cant find it let me know and I will post a picture of it.
Reply With Quote
  #5  
Old 04-08-2012, 04:49 AM
crazymays77 crazymays77 is offline
Ford Truck Driver
 
Join Date: Dec 2011
Posts: 98
Default

The iac valve is new only has done it that one time so Idk what it was. Thanks for the ideas thou
__________________
99 ford ranger xlt stepside 4.0l 4x4 auto.
Reply With Quote
  #6  
Old 04-09-2012, 12:07 AM
slavedeath slavedeath is offline
Learning to use the forums
 
Join Date: Apr 2012
Posts: 2
Default

Could have been bad gas/debris flowing through the injectors. Glad to hear that it worked out.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sputtering While Turning TheThickster General Tech 0 03-06-2012 09:51 PM
sputtering rangercowboy General Tech 0 02-09-2012 06:23 AM
sputtering when i accelerate !!!! tried everything gixxerjosh 3.0 Vulcan Tech 20 11-16-2011 06:03 PM
sputtering problem on 91 1991fordranger 4.0 SOHC / 4.0 OHV Tech 0 10-19-2011 03:59 PM
98 6 Cyl 3.0 Sputtering KyDan General Tech 1 01-28-2010 05:48 PM