Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-24-2012, 11:18 AM
Like the Forums
 
Join Date: Dec 2011
Posts: 40
Default PATS? Will turn over but not starting

Buying this truck I knew that I would have to fix a few things which was no problem but I have a problem that I cant solve. My 99 ranger will turn over but not start. It cranks over and after about 4 seconds of turning over the theft light starts flashing quickly. The weird thing is that I have tried starting it about 2 dozen times over the past week with the same results except for the other night it started. Then again in the morning it would just turn over and not start. Here is what I have and what I have done.

99 ranger
3 body lift
3 suspension lift
new battery
new starter
all fuses are good

I have done alot of reading and most people refer to PATS. The safey control system. I'm thinking that my key has gone bad. With that I have bought a new key with a chip in it but didn't get it programmed to see what result I would get. When I put the new key in nothing happens, its wont even turn over. If I had a second person around I could have them start the vehicle making sure Im getting signal to the coil pack.

I guess I don't see why it started and now it wont. What I was having issues with was my shift linkage between the shifter and transmission broke and I replaced that. That night I started my truck 10 times with no isses and had no prior starting issues. The next morning is when it wouldn't start with the current symptoms.

Thanks in advance
__________________
99 Ranger W/Stuff / 6" lift / BF Goodies / No messin around front bumper / auto /
Reply With Quote
  #2  
Old 02-24-2012, 12:46 PM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,400
Default Re: PATS? Will turn over but not starting

Quote:
Originally Posted by Speed_Trendz View Post
Buying this truck I knew that I would have to fix a few things which was no problem but I have a problem that I cant solve. My 99 ranger will turn over but not start. It cranks over and after about 4 seconds of turning over the theft light starts flashing quickly. The weird thing is that I have tried starting it about 2 dozen times over the past week with the same results except for the other night it started. Then again in the morning it would just turn over and not start. Here is what I have and what I have done.

99 ranger
3 body lift
3 suspension lift
new battery
new starter
all fuses are good

I have done alot of reading and most people refer to PATS. The safey control system. I'm thinking that my key has gone bad. With that I have bought a new key with a chip in it but didn't get it programmed to see what result I would get. When I put the new key in nothing happens, its wont even turn over. If I had a second person around I could have them start the vehicle making sure Im getting signal to the coil pack.

I guess I don't see why it started and now it wont. What I was having issues with was my shift linkage between the shifter and transmission broke and I replaced that. That night I started my truck 10 times with no isses and had no prior starting issues. The next morning is when it wouldn't start with the current symptoms.

Thanks in advance
I am no expert on the PATS module, however on the 95's+ I thought that was part of the "starter control circuit" meaning iif the pats was not working the truck would not crank at all.

here is a link where you can get an owners manual it explains all the anti-theft crap
http://www.ford-trucks.com/user_gall...159299&width=0

I would test for fuel and spark.I also would test for any codes?
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound.
Reply With Quote
  #3  
Old 02-24-2012, 01:02 PM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,400
Default Re: PATS? Will turn over but not starting

I did some googling. it apears with PATS II it might crank and not start.....if you have 2 keys try and make a 3rd one?........there is a lot of info about it on the web.
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound.
Reply With Quote
  #4  
Old 02-24-2012, 10:59 PM
Like the Forums
 
Join Date: Dec 2011
Posts: 40
Default Re: PATS? Will turn over but not starting

Ya I have seen both about the cranking or not. The only thing that leads me to think that it is the pats is because of the theft light. It may be the fuel pump or a relay. I will do some more testing and see what happens. As far as codes go I have had the cluster come up with check gauges but no check engine. I will have to scan it. I only have the one key that appears to be a replica its self. I do have another key that I had cut but not programmed yet.
__________________
99 Ranger W/Stuff / 6" lift / BF Goodies / No messin around front bumper / auto /
Reply With Quote
  #5  
Old 03-08-2012, 08:42 PM
Like the Forums
 
Join Date: Dec 2011
Posts: 40
Default Re: PATS? Will turn over but not starting

Any more ideas?????
__________________
99 Ranger W/Stuff / 6" lift / BF Goodies / No messin around front bumper / auto /
Reply With Quote
  #6  
Old 03-08-2012, 08:52 PM
Ford Motor Company
 
Join Date: Nov 2011
Posts: 138
Default

Check your fuel pump...from my experiences it can work fine one day and the next morning your stuck....happened to me more than once lol
__________________
99 Ranger 3.0, ext cab, auto, Fabtech 5.5 with 33x12.5 Generals, 8.8 rear 4.56 gears detroit locker
Reply With Quote
  #7  
Old 03-08-2012, 09:00 PM
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 3,882
Default

When you put the key in and turn on, do you wait til it stops beeping before starting?
__________________
Not a F150 sellout? Click HERE

Quote:
Originally Posted by robertmcclure View Post
adamantium tamponicus!
Reply With Quote
  #8  
Old 03-08-2012, 09:18 PM
Ford Tough
 
Join Date: Jul 2011
Posts: 237
Default Re: PATS? Will turn over but not starting

Maybe this will help. found this on another site.

PATS uses a visual theft indicator located on top of the instrument panel. This
indicator will prove out for three seconds when the ignition switch is turned to ON
or START under normal operation. If there is a PATS problem, this indicator will
either flash rapidly or glow steadily (for more than three seconds) when the ignition
switch is turned to ON or START. PATS also "flashes" the theft indicator every two
seconds at ignition OFF to act as a visual theft deterrent.

Engine does not start: LED flashes rapidly Leave ignition on until the LED starts to flash a 2 digit code: (sequence- pause-sequence)
Check the following codes:
Code flashes:
1:3 Key code not received. Is key screened by other keys or objects? Try different key: if okay then first key is faulty. If not go to main dealer
1:4 Partial code only received. Try again. If not okay use different key. If not go to main dealer
1:5 Key not programmed into PATS. Program key as above using master
1:6 Faulty link between PATS module and EECV Go to dealer .
__________________
1994 ford ranger 4x4 4.0
3in body lift 3in suspension ramsey 8000lbs winch prerunner winch bumper
KC 100w daylighters 33x13.50 TOYO MT's
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable PATS whfd930 Electrical Tech 12 03-17-2013 03:51 PM
pats help Slk1 Interior Tech 0 10-31-2011 11:00 AM
PATS help please!!! naturecakezzz Electrical Tech 0 03-14-2011 07:13 AM
Question about PATS Fordfan444 Electrical Tech 2 08-27-2010 02:56 PM
Pats / Non pats keys 2005 Edge TheJellyman Electrical Tech 3 10-18-2009 05:47 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.