Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 10-17-2011, 04:45 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default PO171 and PO174 both throwing check engine light on 96 ranger 4.0

hey guys i just changed the egr valve and egr sensor because my truck was showing egr flow excessive and insufficient... now it's throwing the codes PO171 and PO174, both for system 1 and 2 lean banks... i got a TPS sensor and MAF sensor i will be putting on soon hoping those will fix the problem because it will run and idle perfect, then start missing and idling low, and sometimes will idle perfect and quit out of nowhere. this even happens while driving at low rpms. i am thinking TPS but could be wrong. let me know what you guys think and any ideas you may have.
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #2  
Old 10-18-2011, 06:06 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

nobody got any ideas?
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #3  
Old 10-18-2011, 06:52 PM
Ford Tough
 
Join Date: Feb 2010
Posts: 302
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

You have a vacuum leak somewhere the upper intake gasket are known to go bad on the 4.0's
__________________
98 ford ranger xlt ex cab 4.0 v6 auto trans
Reply With Quote
  #4  
Old 10-19-2011, 01:01 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

well from what i've read it could be vacuum leak as you mentioned, TPS (already got a new one just not put on yet), or fuel pump.
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #5  
Old 10-19-2011, 01:07 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default

A vacuum leak is the most common and likely. You can spray ether or Carb cleaner around the vacuum lines to find the leak.

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 10-19-2011, 06:49 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

alright man thanks... where are all the vacuum hoses? the only ones i know of are the two lines running from the egr pipe to the egr sensor and i'm not even positive those are really vacuum hoses.
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #7  
Old 01-18-2012, 06:17 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

well it has been a while since posting in this thread. just wanted to say the problem is still there. i have checked quite a few vacuum lines and fixed 2-3 that were bad but the problem was still there. i have new intake plenum gaskets to put on it probably this weekend. if that doesn't fix it, what other suggestions can you guys give?
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #8  
Old 01-19-2012, 05:04 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

i guess nobody is going to chime in with any other ideas?
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #9  
Old 01-20-2012, 12:27 PM
^thats what they call me^
 
Join Date: Aug 2010
Posts: 378
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

both upstream o2 ssensors. i replaced mine a couple weeks ago but the light came back on recently...
__________________
1998 ranger extended cab, 2wd, 4.0 ohv, 5 speed, sony xploid 52 4 way watt radio, 2 pair of pioneer 240 watt speakers, air horn, Cobra 29 LX LCD CB radio pushing 100 watts, k&n air filter, 15 inch exploder wheels, dual exhaust with 4 inch stainless tips, 2 12 inch subs with a 1000 watt amp just for the hell of it!

new project: barn fresh 1982 yamaha XJ550 maxim.
Reply With Quote
  #10  
Old 01-20-2012, 12:56 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

That code is caused by vacuum leaks. You just haven't found the leak yet unfortunately.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #11  
Old 01-20-2012, 01:10 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

well i'm hoping that when i change the intake plenum gasket this weekend that it'll fix it. but now i keep hearing a weird sound coming from somewhere on the passenger side that sounds like rubbing. it might just be the brakes because mine stick a little every now and then.
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #12  
Old 01-20-2012, 03:28 PM
FX4 MADNESS.
 
Join Date: Jan 2011
Posts: 4,151
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

Valve noise.
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Sno-Way snow plow mount | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #13  
Old 01-20-2012, 04:12 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

Quote:
Originally Posted by 02RangerFX4 View Post
Valve noise.
it's not coming from the engine area... more towards the sides around my wheels, that's why i mentioned that my brakes give me trouble like this every now and then. but it could be my ball joints or bearings, my ball joints have been bad for a while but haven't had the cash to fix them yet... maybe my bearings are going out too, it's always something with this truck haha but i love it to death... by the way, i've drove it short distances and had it up to 50-60mph a little lately and haven't heard the noise anymore so i do believe it was my brakes
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #14  
Old 02-08-2012, 07:22 PM
Ford Motor Co
 
Join Date: Sep 2011
Posts: 171
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

got the intake plenum gaskets on and so far it has been running great with no more problems... it idled for 40-45 minutes without missing or dying and it drives TONS better without even thinking about dying. so i'm fairly sure it's fixed, it hasn't thrown anymore codes.
__________________
1996 Ford Ranger XLT 245 4.0L OHV V6 4X4 Supercab-Flowmaster Super 10 Series W/ 2.5" Piping And 3.5" Tips-15x10 Eagle Alloy Rims W/ 31/10.50R15 Nexen Roadian M/T Tires-Summit Racing 3" Body Lift-Rough Country 4" Suspension Lift-Rough Country 8000 Series Hydro Shocks-Roll Bar-Bedlined Grill/Fender Flares
1990 Ford Ranger Custom 177 2.9L OHV V6 4X4-Trail Rig-Removed Bed-Removed Sway Bars-Front Fenders Pushed In-Black Painted Steel Rims W/ P235/75R15 Goodyear Wrangler A/T Tires
Reply With Quote
  #15  
Old 02-08-2012, 07:30 PM
"Give Her the Biscuits"
 
Join Date: Jun 2010
Posts: 410
Default Re: PO171 and PO174 both throwing check engine light on 96 ranger 4.0

Quote:
Originally Posted by Caseywoods5 View Post
it's not coming from the engine area... more towards the sides around my wheels, that's why i mentioned that my brakes give me trouble like this every now and then. but it could be my ball joints or bearings, my ball joints have been bad for a while but haven't had the cash to fix them yet... maybe my bearings are going out too, it's always something with this truck haha but i love it to death... by the way, i've drove it short distances and had it up to 50-60mph a little lately and haven't heard the noise anymore so i do believe it was my brakes
Is it only at lower speeds, sounds like a quiet growl noise? I have a similar noise coming from my passenger side at lower speeds I'm guessing it has to do with brakes because driveline & front end is tight.

----------

Quote:
Originally Posted by Caseywoods5 View Post
got the intake plenum gaskets on and so far it has been running great with no more problems... it idled for 40-45 minutes without missing or dying and it drives TONS better without even thinking about dying. so i'm fairly sure it's fixed, it hasn't thrown anymore codes.
Glad to hear it man
__________________
SOLD: 1997 Ford Ranger STX 4x4

Current:LIFTED 1995 Ford F150 351W 4x4

WINTER BEATER: BLACK 2000 FORD EXPLORER LIMITED AWD 5.0L V8
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
E85 and codes PO171 and PO174 garo24 3.0 Vulcan Tech 16 03-31-2014 06:40 AM
If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here! 01_ranger_4x4 4.0 SOHC / 4.0 OHV Tech 105 02-18-2014 07:26 AM
Need help with check engine light on newer Ranger Pool Runner 4-Cylinder Tech 0 10-05-2011 08:42 PM
Check Fuel Cap/Check Engine Light Texas001 3.0 Vulcan Tech 9 12-31-2010 10:03 AM
92 ranger 2.3 check engine light question Buddy 4-Cylinder Tech 3 08-01-2009 06:57 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.