Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 11-09-2010, 06:02 AM
MAK MAK is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 14
Default Re: MAF trouble

Clean the Idle Air Control Valve (IAC) first as the MAF won't make this noise. The sound seems to be at the MAF but it's misleading. I cleaned my IAC and MOOSE is gone. I only heard the moose when it got cold and only when I turned the heater on but it sounds like yours is even worse. I think (my opinion here) that cleaning the IAC will also have a positive result in the error code for the O2 sensors as well. After I cleaned my IAC I got "Bank 2 Sensor 1" code for a day and then it went away. I wasn't going to change my sensor as I'd changed the thing twice over the years already and probably didn't need to. Other issues cause the system to flag the sensor and changing the sensor is just fixing the symptom and not the root cause.
__________________
2000, 4x4, 4.0 Ext cab
Reply With Quote
  #17  
Old 11-15-2010, 02:09 PM
markdpro markdpro is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 1
Cool Re: MAF trouble

Quote:
Originally Posted by Jay FX4 View Post
I was not aware that a little electronic sensor was capable of producing sound.
How did you come to the conclusion that that's where the sound was coming from? Are you certain that it wasn't simply your fan turning on?

Also, did the truck run any differently once the sound started?
I think its the idle air control valve. It viibrates and the intake seems to have a harmonic that makes that GROWL. I replaced the IAC valve and problem gone. I almost went to the mass airflow sensor but fortunately came across this solution first. saved me $$$$$$
Reply With Quote
  #18  
Old 11-16-2010, 07:48 AM
MAK MAK is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 14
Default Re: MAF trouble

Glad to hear it helped. These discussions led me to cleaning the IAC prior to changing the MAF sensor as well.
__________________
2000, 4x4, 4.0 Ext cab
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using tow straps: Am I asking for trouble? 02Edge General Ford Ranger Discussion 24 01-25-2011 07:16 PM
having some trouble 94ranger3.0 3.0 Vulcan Tech 21 12-22-2009 08:46 PM
maf to computer trouble? oldfordisbetter 4.0 SOHC / 4.0 OHV Tech 3 11-14-2009 10:19 PM
V6 in trouble Sifurich 4.0 SOHC / 4.0 OHV Tech 4 07-18-2009 08:51 AM
A/C Trouble Draco General Ford Ranger Discussion 1 07-09-2009 02:38 PM