Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-24-2011, 10:30 AM
tiloup tiloup is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 1
Default Starting problem

Hi all, i got a Ranger xlt 1995. If i jump on the solenoid, the car start but if i turn the key, it dont work. I can hear the click but nothing happen. Someone can help me please?
Reply With Quote
  #2  
Old 07-25-2011, 10:07 AM
mrkartoom mrkartoom is offline
mechanic wannabe
 
Join Date: Jul 2011
Posts: 11
Default Re: Starting problem

Seen bad ground cause this on other vehicle, so cleaning connections at starter may be worth a shot. Especially at that age. Good luck.
__________________
2002 4x4 4.0L
Reply With Quote
  #3  
Old 07-25-2011, 10:08 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default Re: Starting problem

could be the starter contacts
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem double b26 Electrical Tech 2 06-01-2011 04:24 AM
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 06:10 AM
88 2.3L Starting Problem 88FordRangerx 4-Cylinder Tech 0 10-01-2010 04:27 PM
2.3L starting problem brokenIN 4-Cylinder Tech 5 09-27-2010 08:38 AM
starting problem lassemista Electrical Tech 1 10-28-2009 11:58 AM