Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-14-2011, 09:11 AM
thechad66 thechad66 is offline
Ford Pickup
Join Date: Dec 2009
Posts: 100
Default Broke 4.0 SOHC

About 3 weeks ago my truck started misfiring real bad. There was a severe loss of power, but luckily I was able to limp home... It was throwing a lot of codes with the check engine light flashing. I've replaced the PCV elbow, the PCV valve, the EGR valve, the DPFE sensor, the intake manifold gaskets and the spark plugs. I also swapped out the coil & swapped some plug wires to try to get the misfire to move. (I rechecked the position of the wires about 10 times.) About 2 months ago i cleaned the IAC valve, throtle body and mas airflow correctly, so they are still clean. The CEL codes now are P0401 (insufficient EGR flow) and P0302 (mis-fire cyl #2.) I also noticed after I got home from a little drive that the passenger's side cat on the Y-pipe was glowing red. I figured that was because the cat was plugged & ordered a new Y-pipe... Unfortunately that was $314 thrown down a hole 'cause after I installed the new Y-pipe, the new cat on the passenger's side was glowing bright red.

I've came to the conclusion that the timing on bank 1 (1,2 & 3) is way off causing the air/fuel mix to get burned/ignited in the manifold infront of the cat. The timing being way off in only 1 bank could possibly due to the crap plastic tensioners and guides that ford put on the 4.0 SOHC. Unfortunately the timing chain for bank 1 is back against the firewall... So... since there is about 135,000mi on my truck, I'm looking for a different motor too put in it... I'm going to go with another 4.0 SOHC... I already have another vehicle i swapped a 5.0 into, so I'm not going that route.

I was wondering if all of my accessories on my motor would bolt up to any (newer) SOHC 4.0... possibly from a newer explorer , because I've heard that ford made the timing chain/tensioners better after 2003 in the explorers... Any insight or advise would be greatly appreciated.

2002 FX4 twin stick red
2007 JKU 6spd
2011 Subaru Outback 2.5i (Wife's)
1966 Bronco
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broke! Fyfe13 General Ford Ranger Discussion 18 06-30-2011 07:12 PM
85 ranger broke in11charlie87 4-Cylinder Tech 3 02-12-2011 08:57 AM
My baby broke! Tadpole 4-Cylinder Tech 6 03-30-2010 04:36 PM
Help, please. wire broke rumpranger 4-Cylinder Tech 3 01-03-2010 04:07 PM
I think its broke....:( baldy3220 4-Cylinder Tech 3 09-03-2009 08:13 AM