Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-14-2011, 08:22 AM
kras20 kras20 is offline
Liking the Ford Ranger Forum
 
Join Date: Jul 2011
Posts: 26
Default starting problems

hey guys i need some help. i just got my 2001 xlt ranger 4x4 with the 4.0l v6 a couple weeks ago and it takes a while to start. ill put the key in the ignition, turn it, and have to hold it any where from two to four seconds before it starts. me and my brother already changed the oil and filter, used seafoam and changed the spark plugs and plug wires. also the throttle body was just cleaned by our mechanic but it still doesnt start right up! i usually have to pump the gas a little too. but once it does start, it runs great!! so what do i need to do to get my truck to start right away????
__________________
2001 4.0L 4x4 stepside
Reply With Quote
  #2  
Old 07-14-2011, 12:02 PM
lvbluesboy lvbluesboy is offline
Like the Forums
 
Join Date: Dec 2010
Posts: 39
Default Re: starting problems

Hey kras20,

Take a look at my "Starting Issue, Kind of Weird" thread and see if it doesn't match your starting problem.

You can try the "run" position a few times trick and see if that helps. It is looking more like the fuel pump check valve is probably the problem, which means changing the pump and the attendant removal of the bed to get access.

Maybe your issue is something different, but it really sounds similiar.
Reply With Quote
  #3  
Old 07-14-2011, 12:19 PM
kras20 kras20 is offline
Liking the Ford Ranger Forum
 
Join Date: Jul 2011
Posts: 26
Default Re: starting problems

thanks for the advice!

i think my issue might be a little different though. It has always started and ive never had to try more than twice before it starts. I'm gona go outside right now and see if turning the key for a few seconds before actually trying to start the engine works!
__________________
2001 4.0L 4x4 stepside
Reply With Quote
  #4  
Old 07-15-2011, 12:17 PM
mrkartoom mrkartoom is offline
mechanic wannabe
 
Join Date: Jul 2011
Posts: 11
Default Re: starting problems

My 2002 always started immediately too until I just recently fixed a vacuum leak, changed the fuel filter, and ran a bottle of Gumout injector cleaner through the tank. All done in reverse order listed and I'm fairly convinced one of them introduced the starting issue. Just not sure which one.

I'm thinking a good place to start would be to have the fuel pressure tested after it has sat for a while. I don't have the pressure numbers you should see, but those should readily be available, as well as when you should see them. The "key on for a bit" before cranking works for a few of us, so that seems to point to a leak down of pressure. Have you noticed a difference when hot or cold?

Isn't the 2001 fuel injected? If so I don't think pumping the pedal is doing anything for you.
__________________
2002 4x4 4.0L
Reply With Quote
  #5  
Old 07-15-2011, 04:05 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: starting problems

Yes the 01 4.0 SOHC is fuel injected. Have you checked the ignition itself & coil pack?
Reply With Quote
  #6  
Old 07-17-2011, 08:31 PM
kras20 kras20 is offline
Liking the Ford Ranger Forum
 
Join Date: Jul 2011
Posts: 26
Default Re: starting problems

i havnt check most of it yet. and when its hot it starts right up but the problem is just when its cold
__________________
2001 4.0L 4x4 stepside
Reply With Quote
  #7  
Old 07-23-2011, 09:15 PM
bjurke bjurke is offline
Ford Tough
 
Join Date: Jul 2011
Posts: 323
Default Re: starting problems

there is one thing you could try. it worked with 3 older ford vehicles i used to have. when you go to start your truck leave your ignition key in the on position for 10-15 seconds before trying to engage the starter. this gives your fuel pump time to pressurize your fuel lines. it is worth a try anyways.
Reply With Quote
  #8  
Old 07-25-2011, 09:59 AM
mrkartoom mrkartoom is offline
mechanic wannabe
 
Join Date: Jul 2011
Posts: 11
Default Re: starting problems

I've heard from another member that the fuel pump runs for 2 seconds when the key is turned on. This makes sense since when I have this problem the first time I turn the key on and wait it rarely starts quick. Turning the key on/off/on and waiting a sec or two each time always works. Guess I'm pumping 2x and getting more pressure. Almost certain this is due to pressure bleeding off, but then this morning after setting for 2 days it fired right up. Go figure.
__________________
2002 4x4 4.0L
Reply With Quote
  #9  
Old 08-02-2011, 07:30 PM
pscranton pscranton is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 12
Default Re: starting problems

I just changed my fuel filter and have this same problem. I had also been low on cash and running on $10 fills up (running on low most of the time) I heard that running on low gums up fuel injectors
__________________
Pscranton-
2007 FX4 4.0L V6 3in BL Rancho 5000's
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
starting problems chris1979 Electrical Tech 0 03-20-2011 01:29 PM
Starting problems... gangrel1109 3.0 Vulcan Tech 2 09-16-2010 11:21 AM
starting problems fordcrazy 3.0 Vulcan Tech 0 07-06-2010 06:19 PM
3.0 Starting Problems CamoCruiser 3.0 Vulcan Tech 3 03-15-2010 05:07 PM
starting problems 1986 ford ranger 2.9 Liter Tech 1 06-27-2009 10:19 PM