Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-11-2011, 04:09 PM
babs67cummins babs67cummins is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 5
Default New ranger owner

hey guys im new to this forum and new to owning a ford ranger. i have a 95, 4.0 5 speed 4x4 i bought the truck as a play truck for around the house. having some problems now with the truck, its got all most 300k on it, i change the plugs and fuel filter. the truck was running pretty good when i got it would stay out at start up onces or twice then would stay running. i was ripping around the house and the cats fell off and ripped the O2 sensor wires right out of the plug. the truck stayed running and didnt have a problem till i shut it down and it wont stay running. will the O2 sensor not being there cause this problem?? im not a big gas motor guy and dont know a whole lot about them so idk if i can get away with maybe puting something in the O2 plug to trick the computer in thinking its on there.

can anyone point me in the right way?
__________________
Daily driver-2008 Dodge Cummins, quad cab, 4x4 with Mods
Play truck- 1995 ranger, 5 speed, 2in body,4in suspension lift
Reply With Quote
  #2  
Old 07-13-2011, 01:32 PM
zman7125 zman7125 is offline
"Give Her the Biscuits"
 
Join Date: Jun 2010
Posts: 410
Default Re: New ranger owner

Buy diesel.
__________________
SOLD: 1997 Ford Ranger STX 4x4

Current:LIFTED 1995 Ford F150 351W 4x4

WINTER BEATER: BLACK 2000 FORD EXPLORER LIMITED AWD 5.0L V8
Reply With Quote
  #3  
Old 07-13-2011, 01:35 PM
Rango88 Rango88 is offline
N/A
 
Join Date: Jan 2011
Posts: 9,031
Default Re: New ranger owner

welcome to frf, I know having the 02 sensor should throw a code, is your engine light on?
Reply With Quote
  #4  
Old 07-14-2011, 07:05 AM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: New ranger owner

What could cause this is plugged cats. Also, clean your MAF, if it's to dirty it's not going to read anything, which causes a no start.

Welcome to FRF
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #5  
Old 07-14-2011, 07:08 AM
Rango88 Rango88 is offline
N/A
 
Join Date: Jan 2011
Posts: 9,031
Default Re: New ranger owner

Quote:
Originally Posted by richarddhoward View Post
What could cause this is plugged cats. Also, clean your MAF, if it's to dirty it's not going to read anything, which causes a no start.

Welcome to FRF
I dont think he has the cats anymore since they fell off.
Reply With Quote
  #6  
Old 07-14-2011, 02:25 PM
babs67cummins babs67cummins is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 5
Default Re: New ranger owner

Quote:
Originally Posted by zman7125 View Post
Buy diesel.
way ahead of ya guy

----------

i have codes. the codes are a non mil code so no check engine. one code if for the o2 heater and another one is for my MAF saying it is intermetenit. the truck will start up then die out but some times if you keep your foot in it and drive it will spit and spudder and then start to run fine but then on the other hand ill give it gas and it will just stay out.

i got a new o2 sensor going to put the cat and o2 back on clear the codes and see if that will fix it
__________________
Daily driver-2008 Dodge Cummins, quad cab, 4x4 with Mods
Play truck- 1995 ranger, 5 speed, 2in body,4in suspension lift
Reply With Quote
  #7  
Old 07-14-2011, 07:37 PM
zman7125 zman7125 is offline
"Give Her the Biscuits"
 
Join Date: Jun 2010
Posts: 410
Default Re: New ranger owner

My 99 did similar to that, it was the IACV.
__________________
SOLD: 1997 Ford Ranger STX 4x4

Current:LIFTED 1995 Ford F150 351W 4x4

WINTER BEATER: BLACK 2000 FORD EXPLORER LIMITED AWD 5.0L V8
Reply With Quote
  #8  
Old 07-16-2011, 07:52 AM
babs67cummins babs67cummins is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 5
Default Re: New ranger owner

well put the cat back on and a new 02 sensor. cleared the codes. truck will idle but when you give it gas it will spit and sputter and then start to run right. i have a code for MAF. idk if its a bad mass air or a wiring problem
__________________
Daily driver-2008 Dodge Cummins, quad cab, 4x4 with Mods
Play truck- 1995 ranger, 5 speed, 2in body,4in suspension lift
Reply With Quote
  #9  
Old 07-21-2011, 02:38 PM
babs67cummins babs67cummins is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 5
Default Re: New ranger owner

well i put a new MAF sensor off a explorer and cleaned the IAT sensor that was packed full of crap and the truck runs alot better now
__________________
Daily driver-2008 Dodge Cummins, quad cab, 4x4 with Mods
Play truck- 1995 ranger, 5 speed, 2in body,4in suspension lift
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New ranger owner whitemike27 Introduce Yourself 13 06-09-2011 04:38 PM
Old Ranger owner since '07 New here lola521 Introduce Yourself 11 05-20-2011 05:44 AM
Another New Ranger Owner jbrockell Introduce Yourself 7 05-10-2010 03:21 PM
New Ranger owner from WY Nathyrin Introduce Yourself 15 04-18-2010 05:18 AM
Possible new ranger owner..... jps37033 Introduce Yourself 4 12-05-2009 11:44 AM