Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-13-2011, 02:29 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Misfire and Shaking

Changed plugs and wires 8 months ago, last week truck began running a code for missfire on 3 and 4 as well as a code for the coil pack (ignition coil). I have replace both 3 and 4 plugs and the ignition coil. The truck is still missfiring and shaking. What next???
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #2  
Old 06-13-2011, 02:31 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Please help

Do #3 and #4 spark plug wires have holes in them?
__________________
2005 Edge

Reply With Quote
  #3  
Old 06-13-2011, 02:36 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Re: Please help

Quote:
Originally Posted by STL View Post
Do #3 and #4 spark plug wires have holes in them?
not that i can see, they were just replace about 8 months ago
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #4  
Old 06-13-2011, 02:40 PM
mossyoak03 mossyoak03 is offline
hillbilly
 
Join Date: Sep 2009
Posts: 657
Send a message via AIM to mossyoak03
Default Re: Please help

you sure you run the wires to the right plugs?
__________________
Mud holes are like a pretty woman with an std, you want to hit but are scared of the consequences!

4wd is like a condom. i'd rather have it and not need it rather tan needing it and not having it!
Reply With Quote
  #5  
Old 06-13-2011, 02:52 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Re: Please help

haha yes, I havent had problems till the last couple weeks
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #6  
Old 06-13-2011, 02:53 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Please help

I would double check those wires. I have seen them go after a month due to the exhaust or something rubbing on them.
__________________
2005 Edge

Reply With Quote
  #7  
Old 06-13-2011, 04:08 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Re: Please help

Quote:
Originally Posted by STL View Post
I would double check those wires. I have seen them go after a month due to the exhaust or something rubbing on them.
will do man thanks. btw im going to run seafoam through do you know which hose im supposed to be running it through?
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #8  
Old 06-13-2011, 04:11 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Please help

hmmm. Well, you've swapped the plugs so it isn't that. You replaced the coilpack, so it isn't that. I would swap some wires around so that 3 & 4 have different wires. See if the problem changes / moves to different cylinders. Just suggesting that over buying new wires for nothing yet.

Seafoam goes in the brake booster vacuum line.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #9  
Old 06-13-2011, 04:28 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Please help

SeaFoam<===CLICK
__________________
2005 Edge

Reply With Quote
  #10  
Old 06-13-2011, 04:37 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Re: Please help

Quote:
Originally Posted by FireRanger View Post
hmmm. Well, you've swapped the plugs so it isn't that. You replaced the coilpack, so it isn't that. I would swap some wires around so that 3 & 4 have different wires. See if the problem changes / moves to different cylinders. Just suggesting that over buying new wires for nothing yet.

Seafoam goes in the brake booster vacuum line.
thanks, I just ran a product through that a mechanic gave me that is professional grade that the public cant buy haha. Anyways, would the problem have anything to do with the MAFS? its only rough when at a steady speed or sitting stopped when in park or drive. it seems to be the worst at 45-55mph. The new coil helped a bit but the roughness is still lingering
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #11  
Old 06-13-2011, 04:43 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Please help

Your misfire would probably not be confined to those two cylinders if it was the MAF. But cleaning it certainly wouldn't hurt.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #12  
Old 06-13-2011, 04:58 PM
mossyoak03 mossyoak03 is offline
hillbilly
 
Join Date: Sep 2009
Posts: 657
Send a message via AIM to mossyoak03
Default Re: Please help

im still saying wires. make sure you have them connected to the spark plugs. one time i was throwing the code for #4 misfire after i did the plugs and wires and somehow the wire broke where it connect to the spark plug
__________________
Mud holes are like a pretty woman with an std, you want to hit but are scared of the consequences!

4wd is like a condom. i'd rather have it and not need it rather tan needing it and not having it!
Reply With Quote
  #13  
Old 06-13-2011, 05:24 PM
Decepticon Decepticon is offline
Black & Orange
 
Join Date: Jan 2011
Posts: 441
Default Re: Please help

yeah ive checked the connections. tomorrow Im going to clean the MAF and if that doesnt change anything, ill do the wires. right now its not throwing any codes but its still running rough...
__________________
1999 Ranger XLT V6 4.0 Orange
EXTERIOR:
- Black signals & Corners (not tinted) | Clear Headlights | silverstar Ultra Bulbs | Black Taillight covers | Painted Black Grille/Valance | Painted black top step on rear bumper | Painted black exhuast & aftermarket Tip | Painted black emblems | Black toolbox | Decepticon Ford badges | 20% tint

INTERIOR:
- JVC Head unit | 4 Kicker door speakers | LED white floor lights |
Reply With Quote
  #14  
Old 10-07-2011, 05:11 PM
jmaplewood jmaplewood is offline
Learning to use the forums
 
Join Date: Oct 2011
Posts: 1
Default Re: Please help

Still having that problem? Ive been struggling with it forever..... long story. Checked everything, 2 new coils, plugs twice, wires twice, injectors,iac, tps, cmp, maf, O2s, even the iat. switched wires, plugs, anything I could. Started about a year ago, came back after 3 months the first time. theres alot more to it, but it would take all day. Anyone able to advise?

2000 Ranger 4WD 4.0 OHV Ex. cab 87k
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 3.0 flex fuel cylinder 5 misfire fixed now 4 misfire error Steve o 3.0 Vulcan Tech 2 10-04-2011 06:19 PM
shaking at speed Riq21 Drivetrain Tech 11 03-25-2011 05:07 PM
Help with shaking prob redjunkie General Ford Ranger Discussion 0 09-09-2010 10:13 AM
shaking at idle sully Other Engine Tech 6 01-09-2010 03:43 PM
shaking shawn 4-Cylinder Tech 8 09-19-2009 03:10 PM