Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-24-2011, 04:02 PM
rbattie99 rbattie99 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 5
Default Engine stalls when shifting from drive to park

2001 4.0L edge

Engine stalls (most of the time) when shifting from drive or reverse to park.
No CEL light illuminated
New plugs\wires
Tranny fluid is ok\new

Engine idles fine in gear and at start up and is fine shifting from park to any gear

Any help is appreciated.

Thanks
__________________
Roy Battie
Reply With Quote
  #2  
Old 05-24-2011, 09:05 PM
FX4OR FX4OR is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 417
Default Re: Engine stalls when shifting from drive to park

what happens when you go drive/reverse to neutral?
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #3  
Old 05-25-2011, 04:43 AM
rbattie99 rbattie99 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 5
Default Re: Engine stalls when shifting from drive to park

Engine keeps running. No change in idle at all. It only happens when going from a gear to park.

Thanks
__________________
Roy Battie
Reply With Quote
  #4  
Old 05-25-2011, 03:09 PM
FX4OR FX4OR is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 417
Default Re: Engine stalls when shifting from drive to park

neutral and park are the same as far as the transmission is concerned, so it sounds like an electrical issue, maybe a short in the steering column related to the shifter park position or some random sensor.

idk how much sense that makes, though, since its a mechanical connection from the shifter to the trans.

does it stop as if you turned the key, or does it sputter and slowly die?
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #5  
Old 05-25-2011, 03:53 PM
rbattie99 rbattie99 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 5
Default Re: Engine stalls when shifting from drive to park

The idle is around 700 rpm in park after the car starts. When I throw it into neutral or a gear it will stay around 700+\-. Sometimes when shifting from gear to park it will idle down to 100rpm then catch itself and return to normal idle. When it does stall it is like the key is turned off.
Thanks
__________________
Roy Battie
Reply With Quote
  #6  
Old 05-26-2011, 10:53 AM
bassmaster bassmaster is offline
Ford Ranger Owner
 
Join Date: Dec 2010
Posts: 57
Default Re: Engine stalls when shifting from drive to park

IAC, and is it an intermittent problem?
Reply With Quote
  #7  
Old 05-26-2011, 11:14 AM
Badmotorfinger1 Badmotorfinger1 is offline
Better than Avg Mechanic
 
Join Date: Jan 2011
Posts: 183
Default Re: Engine stalls when shifting from drive to park

Just throwing this out as a possibility... throttle position sensor.
The ONLY reason I mention this is I had a very similar issue with a Pontiac years ago and after chasing my tail for months a mechanic buddy suggested we drive around with his Snap On real time diagnostic tool hooked up and we stumbled on the TPS voltage fluctuating and without throwing the CEL. The voltage fluctuation would stall the engine.
__________________
2000 XLT 4WD 4.0L OHV, 5 spd, Alabama Cylinder heads, Delta Cams Valve Train and Pushrods, JBA Headers, KKM Cone Air Cleaner, BBK Throttle body, Dynomax Cat-Back exhaust, Summit Racing drilled front rotors w/ EBC pads, Cobra rear disk brake conversion w/ Hawk pads, 8.8" 4.10 Traction-Lok
Reply With Quote
  #8  
Old 05-27-2011, 07:27 AM
rbattie99 rbattie99 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 5
Default Re: Engine stalls when shifting from drive to park

Will try this weekend and report back

Thanks
__________________
Roy Battie
Reply With Quote
  #9  
Old 10-19-2012, 08:45 AM
anthem anthem is offline
Ford Tough
 
Join Date: Jun 2012
Posts: 259
Default Re: Engine stalls when shifting from drive to park

I know this is an old thread but did anyone have a definate answer for this? Mine is doing the same thing.
__________________
Sold, I'm no longer one of you.
Reply With Quote
  #10  
Old 10-20-2012, 02:50 PM
rbattie99 rbattie99 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 5
Default Re: Engine stalls when shifting from drive to park

Vacuum leak on passenger side in front of engine. Was on the underside of the hose so you have to inspect really well
__________________
Roy Battie
Reply With Quote
  #11  
Old 02-06-2015, 05:07 AM
TB-9862 TB-9862 is offline
"How hard could it be?"
 
Join Date: Jan 2012
Posts: 2,179
Default Re: Engine stalls when shifting from drive to park

Found this through search ..

Mine just started doing the same thing last night. Will check for vacuum leak after work.

My 01 with the 3.0 used to idle around 800rpm but my 01 4.0 idles at 500. Was thinking there might be a set screw on the throttle cable lever like on the 3.0 if I could manually adjust the idle speed?
__________________
Dennis Brady

Black 2001 4x2 XLT Supercab 3.0 "Shadow" - WIA

Black 2001 4x4 EDGE Supercab 4.0 ('Body donor' for Shadow lol)

Build thread:
http://www.fordrangerforum.com/proje...adow-redo.html
Reply With Quote
  #12  
Old 02-06-2015, 10:42 AM
Robramrod Robramrod is offline
Ford Motor Co
 
Join Date: Feb 2011
Posts: 152
Default

They have the 4.0 listed as a non adjustable idle the computer does all of the adjusting the stop screw is not meant to adjust the idle speed as the idle speed fuel trim is the only way to change the idle.
Reply With Quote
  #13  
Old 02-25-2015, 08:28 AM
Robramrod Robramrod is offline
Ford Motor Co
 
Join Date: Feb 2011
Posts: 152
Default

The screw on the throttle body only adjusts cable tension not idle speed.
Reply With Quote
  #14  
Old 02-25-2015, 04:25 PM
TB-9862 TB-9862 is offline
"How hard could it be?"
 
Join Date: Jan 2012
Posts: 2,179
Default

Aye, realized that after going out and actually looking at it lol

My problem was caused by dirty IAC. Cleaned it up and now it still idles around 500 but doesn't buck or stall anymore.
__________________
Dennis Brady

Black 2001 4x2 XLT Supercab 3.0 "Shadow" - WIA

Black 2001 4x4 EDGE Supercab 4.0 ('Body donor' for Shadow lol)

Build thread:
http://www.fordrangerforum.com/proje...adow-redo.html
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC stalls engine when it cycles on Tonto 4.0 SOHC / 4.0 OHV Tech 16 07-12-2011 11:58 AM
Problem Shifting Out of Park RanCot23 Drivetrain Tech 3 01-25-2010 09:18 PM
engine stalls when put in park AllBlackRanger4x4 General Tech 3 01-06-2010 07:07 PM
Truck won't start in park... and won't engage into Drive Steve G. Drivetrain Tech 3 08-29-2009 06:41 PM
Engine Stalls Jared General Tech 2 07-02-2009 07:45 PM