Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-09-2011, 08:38 AM
biggun6ss biggun6ss is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 2
Default Dead Cylinder

My brother and I changed out his valve cover gaskets but messed up when attaching the plug wires. We had them wrong when we started the truck; knew pretty quickly when the truck would not run. We looked in the manual and got the wiring correct but now the number 3 cylinder is dead. We pulled the spark plug and the metal tip looked bent. I don't know if when starting the truck with the incorrect firing order caused this. We have good spark so it is something else.

Was wondering if anyone else made this mistake and experienced the same problem. I am thinking it may be a valve issue but have never been inside this motor. When ideling the truck sounds fine, a little rough, but no metel to metal sounds.
Reply With Quote
  #2  
Old 05-10-2011, 11:09 AM
biggun6ss biggun6ss is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 2
Default Re: Dead Cylinder

Found the problem

The number 3 injector was unplugged.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is Rock dead? RangerChad Music/Movies/Computers/etc. 22 07-23-2011 04:42 PM
Dead timlizzy General Tech 10 05-03-2011 03:35 AM
Help diagnosing dead #5 cylinder Soundside 3.0 Vulcan Tech 0 04-25-2011 02:41 PM
dead headlights 88 2 wd striper2301 General Ford Ranger Discussion 2 12-09-2009 12:32 PM
My Duck is dead greyghost Laugh Factory 1 10-30-2009 05:18 AM