Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 05-08-2011, 08:46 AM
Blade Blade is offline
Learning to use the forums
Join Date: Apr 2011
Posts: 7
Default Starting Problum with High Idle

For some reason my ranger will start if its been sitting for about 6hrs or so with no problum. However if after I start it and trun it off then go to restart it, it is turning over but will not start all the time, most of the time I have to step on the gas to get it to start and it will not take a jump. It is also idleing high when it first starts about 2000 to 2200rpm then drops down slowly to around 1500rpm. Or will drop down if I put it in drive or reverse. It used to idle around 1000rpm when in park.

I had the codes pulled and there were no codes. So I put in a new IAC valve and that didnt fix it.

It does have an exsust leak at a flang (the flang next to the transmision) I got to get fixed and that came lose about the same time but I really dont think it is that.

Any suggestions as to were to look and fix lol, or anyother info ya might need to help me would be great. Oh its a 95 ranger automatic v6 4.0.

1995 Extcab Ranger V6 4.0 Auto
Reply With Quote
Old 05-08-2011, 04:02 PM
BOBBO BOBBO is offline
Join Date: May 2010
Posts: 50
Default Re: Starting Problum with High Idle

Take apart your throttle body, clean and inspect it and see it it helps.
Infinity Basslink
Firestone Destination A/T
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 05:10 AM
High Idle on 87 2.3. Kmartcivic 4-Cylinder Tech 0 02-13-2011 09:01 AM
High Idle Blackhole2001 4-Cylinder Tech 0 12-20-2010 10:09 PM
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 05:50 AM
2004 Ranger (4.0) High Idle when first starting??? Frez1812 4.0 SOHC / 4.0 OHV Tech 9 10-21-2010 12:11 PM