Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-29-2011, 06:45 PM
blackstangt70 blackstangt70 is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Default Need some Help ( Truck wont run under WOT )

I'm new here but this site but i have been lurking on here for a while. Ive got a 94 4.0 2wd auto. The truck runs and idles great if you take it easy on it. But as soon as you hit a hill or try to rev it fast it bogs and looses all power and wont pick back up till you let off to about half throttle. Its been doing this for a while and I've tried a new fuel regulator, pump, and filter. I've also checked all the vacuum lines that i know of but still can't solve the issue. any ideas?
Reply With Quote
  #2  
Old 04-29-2011, 06:56 PM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: Need some Help ( Truck wont run under WOT )

MAF, injectors, fuel pump, fuel filter. Start with the filter, and move to the more expensive parts. Clean the MAF, clean or replace the injectors, and finally replace the pump if the issues still arise.

----------

sorry, re read your OP, disregard what I said pertaining to parts you already replaced.

----------

so that leaves you with the MAF and injectors.
__________________
1999 B2500 5 Speed
Reply With Quote
  #3  
Old 04-29-2011, 07:52 PM
blackstangt70 blackstangt70 is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Default Re: Need some Help ( Truck wont run under WOT )

okay thanks. I will try the MAF and injectors tomorrow. Thanks for the info.
Reply With Quote
  #4  
Old 04-30-2011, 08:42 PM
blackstangt70 blackstangt70 is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Default Re: Need some Help ( Truck wont run under WOT )

Thanks for the help obsolete. Today i cleaned the MAF, TB, and some other various sensors. The truck runs way better than it did this morning. Has the power it used to. I also used some seafoam in the tank. Runs great the truck has sit for about 7 months so i think now with some drive time it will bak to 100% thanks for the help again
Reply With Quote
  #5  
Old 04-30-2011, 09:22 PM
fstcarkid fstcarkid is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Re: Need some Help ( Truck wont run under WOT )

do a tune up on it ASAP!!! run some more seafoam through. change the oil, filter, plugs, wires, tranny fluid/filter and check the coolant to see how that is. get some new fluids in it. since you did the seafom, your going to have to do an oil change soon any way, like, within the next 300 miles. your truck should run good then
__________________
The difference between stupidity and genius is that genius has it's limits
the definition of insanity doing the same thing over and over again and expecting different results
ya, i can be a dick, dont like it? put a bullet in ur brain
its hard to find good help

"i used to sell, i know pot math"- smakes
Reply With Quote
  #6  
Old 05-01-2011, 04:51 AM
Botta Ranger Botta Ranger is offline
Ford Tough
 
Join Date: Jan 2011
Posts: 240
Default Re: Need some Help ( Truck wont run under WOT )

Quote:
Originally Posted by fstcarkid View Post
do a tune up on it ASAP!!! run some more seafoam through. change the oil, filter, plugs, wires, tranny fluid/filter and check the coolant to see how that is. get some new fluids in it. since you did the seafom, your going to have to do an oil change soon any way, like, within the next 300 miles. your truck should run good then
Why on earth would he want to do all that crap?
Reply With Quote
  #7  
Old 05-01-2011, 04:49 PM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: Need some Help ( Truck wont run under WOT )

Quote:
Originally Posted by blackstangt70 View Post
Thanks for the help obsolete. Today i cleaned the MAF, TB, and some other various sensors. The truck runs way better than it did this morning. Has the power it used to. I also used some seafoam in the tank. Runs great the truck has sit for about 7 months so i think now with some drive time it will bak to 100% thanks for the help again
NP, glad it worked out for you.
__________________
1999 B2500 5 Speed
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! My truck won't run sled dog 3.0 Vulcan Tech 5 04-10-2011 10:37 AM
WOT jerk STFUandRTFM 3.0 Vulcan Tech 14 04-08-2011 02:53 AM
94 Ranger wont shift under WOT buckachow Drivetrain Tech 1 05-01-2010 10:13 PM
1994 wont run madmax 3.0 Vulcan Tech 4 08-15-2009 11:26 PM
Truck wont start tj88 Drivetrain Tech 1 08-01-2009 02:31 PM