Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-08-2009, 08:06 AM
RandSand RandSand is offline
Ford Truck Driver
 
Join Date: Oct 2009
Posts: 85
Default High idle & running rich

Hello:
My 04 is has a high idle for about 2 minutes when have a cold start. It is not rough, just on the high side. After 2 minutes it is normal. Is this normal? I live in Fl so the weather is very warm. It reminds me of when I lved up North and the car had to warm up.

I also have 2 codes, L & R banks running rich. I have cleaned the throttle body, MAF and the Throttle contral valve and the codes still pop up.

Any suggestions, tips, etc would be great.

Thanx!!
__________________
2004 XLT 4x4 4.0 42K miles
Reply With Quote
  #2  
Old 10-08-2009, 10:39 AM
Rangermuse Rangermuse is offline
Do Work
 
Join Date: Sep 2009
Posts: 31
Default

O2 sensors. Pull them test the resistance in them and if need be replace them
__________________
Romans 8:18
Reply With Quote
  #3  
Old 10-08-2009, 11:18 AM
RandSand RandSand is offline
Ford Truck Driver
 
Join Date: Oct 2009
Posts: 85
Default

Thanks!. Would yo know how Many O2 sensors and where they would be located?
__________________
2004 XLT 4x4 4.0 42K miles
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan Speed-High Only redfish10 General Tech 10 09-16-2011 08:02 AM
high rpm blkranger 3.0 Vulcan Tech 2 10-08-2009 11:20 AM
not running right redneck_ranger_1991 2.9 Liter Tech 1 04-26-2009 11:10 PM
Running HOTT Rangerman General Ford Ranger Discussion 3 03-04-2009 06:54 PM
My ford Ranger 05 keeps making this high pitch noise when in high gear? rickymercer17 General Ford Ranger Discussion 1 12-08-2008 07:40 PM