Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-17-2011, 09:45 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default IAC and throttle cleaned now high idle?!

Today I seafoamed the truck, new plugs wires, screamin demon coil pack and oil change. So I decided to clean the IAC and throttle, came out real nice...BUT now everything is back on it started idling at 2k, I swapped another IAC in, it dropped to 1500 rpm then to 1000rpm My truck as always idled at 500-600 rpm. There is a sensor that goes on the side of the throttle here on the side



I put the sensor on, it has to be put up on an upward angle like this


Then pushed down to line the screw holes up like this, and by doing that, it turns the cylinder a bit once its lined up


When I start my truck it is steady at 1k at idle, I give it gas it races to 2k rpm then after a minute drops to 1k. I loosen the screw to that sensor, when it moves the idle jumps. Am I messing up here or what?

Last edited by Clinton; 04-17-2011 at 10:54 PM.
Reply With Quote
  #2  
Old 04-17-2011, 10:38 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

Ok, took it out for a drive real quick. In park it idles at 900 rpm, in gear idles at 800 rpm. When in park if I rev it once and let off, the idle will drop to 1500rpm for a few seconds then it will drop to 900 rpm. So WTF is going on? Anyone??
Reply With Quote
  #3  
Old 04-17-2011, 11:13 PM
Rango88 Rango88 is offline
N/A
 
Join Date: Jan 2011
Posts: 9,031
Default Re: IAC and throttle cleaned now high idle?!

maybe you have a vtec now . sorry, I have no idea just wanted to say soemthing stupid.
Reply With Quote
  #4  
Old 04-17-2011, 11:18 PM
DeepSouthRanger DeepSouthRanger is offline
Don't Stop Modding!!
 
Join Date: May 2009
Posts: 545
Default

That sensor had to be clocked in the right direction or it will be off. Try putting on towards bottom and moving up to line up holes. I had to play with mine to get the pre loaded on the spring right.
__________________
So Many Mods,So little Time!!

Preformance:
SCT Livewire w/ Rogue tunes,Rogue Larger MAF Housing w/ card type sensor,MAC cold air intake,40 series FLOWMASTER exhaust w/ duals,Set of 1.7 Roller rockers,full set of under drive pulley's(Blue),Screamin demon coil,8mm heat braided wires(Blue),double patium plus,Gator back belt,200 amp(power coated blue) Alt.,Taurus fan
Reply With Quote
  #5  
Old 04-17-2011, 11:23 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

I have been trying that as well. The only way I can get it on is by putting it in a slightly upward position and putting it back down. I spent about 2 hours trying to fit it without doing that and even tried it on another throttle body and it fits the same way

It should have a little pre load on it right?

Last edited by Clinton; 04-17-2011 at 11:25 PM.
Reply With Quote
  #6  
Old 04-18-2011, 01:00 AM
DeepSouthRanger DeepSouthRanger is offline
Don't Stop Modding!!
 
Join Date: May 2009
Posts: 545
Default

Yea! Got to have the pre load..
__________________
So Many Mods,So little Time!!

Preformance:
SCT Livewire w/ Rogue tunes,Rogue Larger MAF Housing w/ card type sensor,MAC cold air intake,40 series FLOWMASTER exhaust w/ duals,Set of 1.7 Roller rockers,full set of under drive pulley's(Blue),Screamin demon coil,8mm heat braided wires(Blue),double patium plus,Gator back belt,200 amp(power coated blue) Alt.,Taurus fan
Reply With Quote
  #7  
Old 04-18-2011, 05:09 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

Well shit, I'm doing it so I have no friggin clue

----------

Quote:
Originally Posted by DeepSouthRanger View Post
That sensor had to be clocked in the right direction or it will be off. Try putting on towards bottom and moving up to line up holes. I had to play with mine to get the pre loaded on the spring right.
I tried putting it in from the downward position, when I turn it up to line up the holes it turns the whole throttle lever backwards
Reply With Quote
  #8  
Old 04-18-2011, 05:48 AM
DeepSouthRanger DeepSouthRanger is offline
Don't Stop Modding!!
 
Join Date: May 2009
Posts: 545
Default Re: IAC and throttle cleaned now high idle?!

Nope then you had it right. The pre load is on the spring so that it pulls the throttle all the way back when you let off. Have you checked for a vacum leak??
__________________
So Many Mods,So little Time!!

Preformance:
SCT Livewire w/ Rogue tunes,Rogue Larger MAF Housing w/ card type sensor,MAC cold air intake,40 series FLOWMASTER exhaust w/ duals,Set of 1.7 Roller rockers,full set of under drive pulley's(Blue),Screamin demon coil,8mm heat braided wires(Blue),double patium plus,Gator back belt,200 amp(power coated blue) Alt.,Taurus fan
Reply With Quote
  #9  
Old 04-18-2011, 06:27 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

Yeah, I didnt mess with anything but the IAC and throttle body. It ran fine until I did the cleaning of them. Is there a way to mess up the IAC when you clean it? I have 2 of them but the same thing happens when I swap them out. The idle revs when the TPS sensor is moved so thats why I thought that would be it. I just took it out and it idles at 1k in park so no change
Reply With Quote
  #10  
Old 04-18-2011, 08:09 AM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: IAC and throttle cleaned now high idle?!

This whole situation is weird, any codes?
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #11  
Old 04-18-2011, 08:34 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

Nope no codes
Reply With Quote
  #12  
Old 04-18-2011, 08:45 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: IAC and throttle cleaned now high idle?!

See, pulling a Scott doesn't always pay off now does it?

lol. Usually when the IAC craps out it idles low, not high. Are you sure you're not pulling a double foot? Trust me, it's easy to do when you're focusing on something else.
Reply With Quote
  #13  
Old 04-18-2011, 08:46 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

WTF is a double foot?
Reply With Quote
  #14  
Old 04-18-2011, 10:57 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

I may have figured it out. I believe the previous ownermay have had the throttle screw turned in too much. Once I turned it out a bit it idled down to where it was before. I am assuming he never cleaned the IAC or throttle body because it was pretty nasty and maybe made up for that by cranking in that screw. Any guru's out there think thats a possibility?
Reply With Quote
  #15  
Old 04-22-2011, 06:00 PM
Adam aka Buddha Adam aka Buddha is offline
Resident Mainah
 
Join Date: Sep 2010
Posts: 89
Default Re: IAC and throttle cleaned now high idle?!

I'm not a guru but that had just happened to me about a week ago. I had problems with it not holding RPM though. At first, since I had only worked on older vehicles just turned the screw to keep it idling right and soon found that it really didn't do much.

I then brought it down to my friend's shop where they luckily had a used IAC there and after I replaced it the truck still idled high. (I had forgot about the screw)

Long story short, I had adjusted the screw and when I changed the IAC it was idling high. Just set your screw and you should be fine.
__________________
1997 Ranger XLT 4.0L V6 Auto 4x4 6000k DDM HID,
3 Inch PA Body lift, 285/75/R16 Goodyear MT/R,
Pioneer sound system, Flowmaster Super 40 SI/SO 2.5",
Custom front and rear bumpers, 130W KC's, 06+ Mirrors.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
cleaned the MAF,IAC,throttle plate, + glamor pics with the 4 door ranger Ranger_EDGE Vehicle Snapshots 15 12-08-2011 05:53 PM
cleaned the IAC still acts up olblue88 2.9 Liter Tech 0 01-26-2011 05:46 PM
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 06:50 AM
just cleaned IAC valve, worse than before trcothorn 4-Cylinder Tech 4 04-12-2010 08:03 AM
High idol on '97-IAC troubleshooting denverdamon 3.0 Vulcan Tech 2 08-19-2009 05:46 AM