Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 04-22-2011, 09:44 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

Thanks Adam! I have been doing my homework and checking my chilton book which I should have done in the first place. By turning the screw out, it still seemed like it wasnt running right, I used almost 1/2 tank of gas in 42 miles which wasn't good. It seemed not to be the same so I finally soved the problem. The dumb ass I am followed the "How to" But failed to realize some throttle cleaners have solvents. I used this throttle cleaner on both of my IAC's and both throttle bodies. Throttle bodies turned out great, the IAC looked great as well. Turns out the solvent ruined both IAC's, thats why swapping them didnt help because I ruined both. Tonight I turned the screw back to its normal position, and put on a brand new IAC and the Hooligan runs beutiful!!

So word to the wise when cleaning your IAC.... DO NOT USE A SOLVENT!!
Reply With Quote
  #17  
Old 04-23-2011, 07:18 AM
Adam aka Buddha Adam aka Buddha is offline
Resident Mainah
 
Join Date: Sep 2010
Posts: 89
Default Re: IAC and throttle cleaned now high idle?!

No problem, just trying to do my part.

That'll do it though. Gotta watch out what you use!
__________________
1997 Ranger XLT 4.0L V6 Auto 4x4 6000k DDM HID,
3 Inch PA Body lift, 285/75/R16 Goodyear MT/R,
Pioneer sound system, Flowmaster Super 40 SI/SO 2.5",
Custom front and rear bumpers, 130W KC's, 06+ Mirrors.
Reply With Quote
  #18  
Old 04-23-2011, 10:51 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

LOL, yeah for sure man. I appreciate the input though, thank you
Reply With Quote
  #19  
Old 04-23-2011, 11:01 AM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: IAC and throttle cleaned now high idle?!

Hey what did you use? I cleaned mine just yesterday with MAF sensor cleaner. Now that's definitely a solvent.


I DID have a MIL come on, but that's cause I didn't plug the TPS back up.
hooked it up, watched my TPS % respond and then erased the code.
running great.

So what lead you to believe that solvent ruined your two IACc?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #20  
Old 04-23-2011, 11:07 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: IAC and throttle cleaned now high idle?!

I used a throttle cleaner called benny's something. I never heard of it but got it anyway. When I looked through the Chilton book, it was in bold black letters DO NOT USE A SOLVENT TO CLEAN IAC So I decided to buy a new one to try it out and sure enough thats what it was. I dont know how it was ruined by the solvent but I am happy it is taken care of
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
cleaned the MAF,IAC,throttle plate, + glamor pics with the 4 door ranger Ranger_EDGE Vehicle Snapshots 15 12-08-2011 05:53 PM
cleaned the IAC still acts up olblue88 2.9 Liter Tech 0 01-26-2011 05:46 PM
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 06:50 AM
just cleaned IAC valve, worse than before trcothorn 4-Cylinder Tech 4 04-12-2010 08:03 AM
High idol on '97-IAC troubleshooting denverdamon 3.0 Vulcan Tech 2 08-19-2009 05:46 AM