Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-09-2011, 05:58 PM
iTzMetal iTzMetal is offline
Ford Fan
 
Join Date: Apr 2011
Posts: 17
Default High Idle?

My truck has been idling rough so I took the TB and the IACV and cleaned them both with ether. I let them dry out for about two hour in front of a fan and put everything back together. Now when I start up my truck it will idle at about 1000 for about 10-20 seconds then jump up to about 2000 for 5-10 second then drop back down to about 750-1000 and start idling shitty. Any ideas. Thought maybe a vacuum leak.

P.S. The engine light just came on but have not had time to pull the codes.

Edit: Took her for a test drive and it isn't shifting correctly and the back brakes are sticking (dont know what thats about)
__________________
2004 4.0L SOHC V6 Fx4 XLT Off Road Automatic Extended Cab Style Side Ford Ranger

Last edited by iTzMetal; 04-09-2011 at 06:34 PM.
Reply With Quote
  #2  
Old 04-10-2011, 11:40 AM
iTzMetal iTzMetal is offline
Ford Fan
 
Join Date: Apr 2011
Posts: 17
Default Re: High Idle?

Update: So I went down to autozone a bit ago and had them pull the codes for me and got P0122 for the TPS. So I bought a new TPS (throttle position sensor) and put it on. Still doing the exact same thing. Wondering if I didnt put the TPS on correctly cause when I put it I had to turn the throttle so it would go on. When I turned the truck on it was holding it at WOT. So I pushed the throttle down and heard a loud click click come from the TPS?!? So i took it back off and now the middle part spins freely. ANY HELP WOULD BE APPRECIATED.

Edit: Whenever I shake the TPS (old one an new one) I can hear something rattle around in them. Should do that right.
__________________
2004 4.0L SOHC V6 Fx4 XLT Off Road Automatic Extended Cab Style Side Ford Ranger

Last edited by iTzMetal; 04-10-2011 at 11:45 AM.
Reply With Quote
  #3  
Old 04-17-2011, 02:07 PM
nophoguy nophoguy is offline
b4000 driver
 
Join Date: Feb 2010
Posts: 2
Default Re: High Idle?

I decided to clean TB, MAF, IAC about a month ago for better mpg's-Turned out i got some cleaner in an area of the IAC that was no good-started up the truck and was idling 1600-1800 rpm-i ruined my IAC and got a new one-around 40 bucks-fixed it right up
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle on 87 2.3. Kmartcivic 4-Cylinder Tech 0 02-13-2011 10:01 AM
High Idle Blackhole2001 4-Cylinder Tech 0 12-20-2010 11:09 PM
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 06:50 AM
High Idle Problem with AC on miljeep66 4-Cylinder Tech 6 06-26-2010 02:19 PM
2.3 high idle bob_rhoades78 4-Cylinder Tech 0 03-23-2010 06:31 PM