Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 10-03-2009, 08:01 AM
Clem Clem is offline
Ford Tough
Join Date: Aug 2009
Posts: 331
Default 92 4.0 low oil sending unit

Have this devise on the left side of the oil pan about 1 1/2" up from bottom.
Mine has a bare wire coming out of it and I'm betting it isn't supposed to be that way.
Can anyone steer me in the right direction to find another one, I will probably have to go to the ASY for the harness.


For those of you who may have this part, or know someone who does, it goes here, but can be on either side of the pan.

They are found on a number of vehicles, not just Ford, but that is what this is related to, mine is a 4.0 OHV.

This is from a Mustang forum
PLENTY of Fords came with oil level sensors and indicator lights including 84ish Mustang GT through 96, 84-86 3.8 Mustang, 85ish-?? 2.3 Mustang, Thunderbird Super Coupe, early Explorer 4.0, certain years of Crown Vic and Grand Marque.

This is a new one, found it listed on
Thought someone might find a use for the info.


Last edited by Clem; 10-07-2009 at 09:09 AM.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
water temperature indicator sender unit kjahwest 4-Cylinder Tech 1 09-19-2009 06:50 PM
NEED HELP INSTALLING Auxiliary Input for 2002 XLT CD Changer unit steveb8699 Electrical Tech 2 07-27-2009 07:11 AM
Wiring Sequence - Sending Unit jvploeg 4-Cylinder Tech 0 06-25-2009 06:36 PM