Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-29-2011, 05:59 PM
02RangerFX4 02RangerFX4 is offline
Lil' Red
 
Join Date: Jan 2011
Posts: 6,369
Default Ranger 4.0l electrical problems?

One morning i started up the 02 fx4 and it was working fine, all of the sudden the motor sputtered some and quit. i saw that the battery was dead and i replaced the battery because its a 8 year old optima battery. now i think that the re manufactured gm alternator is weak, i got in the new battery and detached the battery after i started it to see if the alternator would keep the truck running, it did fine, but the gauges in the truck started to wiggle and the light would flicker a little but not a lot. i revved the engine, sounded fine but when i hooked the battery back up the engine didn't change rpm's but i dead hear a small woosh sound. like the air intake was rapidly sucking in air but again, the engine never went above idle. could possibly the alternator be weak and actually sucking energy from the battery? i don't want to replace my alternator unless i need to. Also i checked under the cover that says 4.0 to make sure my throttle cable isn't loose, (which it isn't, its just the pedal) and i noticed a red plastic tipped wire the fed through a tube into a metal box that said 02 ranger gas or something. it was right next to the throttle. Does anyone know what it is?
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Rebello Racing cams | port and polished heads | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #2  
Old 03-29-2011, 06:09 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Ranger 4.0l electrical problems?

First, do not ever disconnect the battery with the engine running. Bad things can happen.

Just have the alternator tested. I'm not sure why you actually think there is a problem though. You said you replaced the battery and it was running fine. I don't see where there is actually a problem.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 03-30-2011, 02:20 PM
02RangerFX4 02RangerFX4 is offline
Lil' Red
 
Join Date: Jan 2011
Posts: 6,369
Default Re: Ranger 4.0l electrical problems?

the reason why i think there is a problem because as i stated up there, the tuck started with the old battery, but the battery was weak, and only had enough to start the truck, i left it running for 15min and when i came back it showed the battery light on the dashboard of the truck, i revved the engine it revved then made a throaty sound like the engine was all of the sudden cut off when i let go of the gas and continued to do that for a few seconds after it went to idle, i tried pulling out (Its a manual which i know yo can dump the clutch and the engine) but the idle rpms were way too low and i didn't let go of the clutch yet. i got the rpm to around 2000 and let go of the clutch a little, the engine wasn't as powerful as it should be and i put it into neutral. the rpm were below the 500 mark but not by much then the gauge went to zero but the engine didn't quit yet. It got lower when the gauge quit but it didn't die till about 5 seconds later. but it sputtered then died. when i put the new battery in the engine was fine i revved it to about 4500 and it was back to normal so i thought the engine was using the battery backup, thats why i disconnected the battery.
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Rebello Racing cams | port and polished heads | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #4  
Old 03-30-2011, 07:23 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Ranger 4.0l electrical problems?

Really hard to follow any of that. But none the less, you concluded this by saying with a new battery, everything is working as intended. So what is the problem now?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Tags
4.0l, alternator, electrical, problems, throttle

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
96 Ranger, multiple electrical problems!! xlr82v2 Electrical Tech 2 09-08-2010 03:56 PM
electrical problems hess1222 Electrical Tech 16 06-14-2010 08:11 AM
Big Electrical and A/C problems HELP!!!!!!!!!!!!!1 hgarza10 Electrical Tech 1 04-16-2010 03:48 AM
Electrical Problems sgampp01 Electrical Tech 1 03-30-2010 01:10 PM
need help 95 ranger electrical wigly1541 General Ford Ranger Discussion 1 07-19-2009 12:50 PM