Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-18-2011, 01:29 PM
Abednarski Abednarski is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 1
Default 95 Ranger 4.0 having problems starting, after sitting for a while

I have a 95 ranger 2wheel drive 4.0 5 speed manaul. my truck is having problems starting after sitting a while.

i have recently put a new computer in because the last one failed, which was the thought at first of it not starting. we put in a new one and it still wouldn't go. Also has a new fuel pump, fuel filter, new control relays, new IAC, new coolent temp sensor. i haven't tried the crankshaft sensor yet, but i haven't seen any improvement in the starting.

it almost seems like it is building pressure and it will the start right away after the fuel pump is running for awhile. once it starts you can turn it off and it fires up right away. the truck runs great when it starts, never bogs down or anything.

anyone have any ideas???
Reply With Quote
  #2  
Old 03-21-2011, 09:26 PM
Flashgordy Flashgordy is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 7
Default Re: 95 Ranger 4.0 having problems starting, after sitting for a while

Have you tried new spark plugs and wires, or ignition module?
Also could be your crank sensor.
__________________
1995 XLT ext cab 2wd 4.0
K&N intake, flowmaster exhaust.
Reply With Quote
  #3  
Old 03-25-2011, 02:08 PM
Rednotch93 Rednotch93 is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 3
Default Re: 95 Ranger 4.0 having problems starting, after sitting for a while

Possibly a bad battery?
Reply With Quote
  #4  
Old 03-25-2011, 03:15 PM
brinker88 brinker88 is offline
TTB man
 
Join Date: Aug 2010
Posts: 1,920
Default Re: 95 Ranger 4.0 having problems starting, after sitting for a while

Correct computer?
__________________
1993 Ford Ranger Ext. Cab | stepside | 4x4 | 4.0L | Lifted | 35" BFG KM2s | MT Classic IIs | Dana 35/Disc 8.8 with 4.56's | Duals | Etc

RIP JASON
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger Truck - Bad Clutch & Starting Problems? Dingo444 Drivetrain Tech 4 02-27-2012 10:38 AM
Starting problems... gangrel1109 3.0 Vulcan Tech 2 09-16-2010 11:21 AM
Starting problems calranger General Tech 6 03-15-2010 07:13 PM
3.0 Starting Problems CamoCruiser 3.0 Vulcan Tech 3 03-15-2010 05:07 PM
starting problems 1986 ford ranger 2.9 Liter Tech 1 06-27-2009 10:19 PM