Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-19-2011, 06:12 PM
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 953
Arrow The Infamous P0171 and P0174 codes troubleshooting

alright, lately i have been experiencing this issue, i have taken out the MAF sensor, cleaned it with MAF Cleaner and also even tried replacing the MAF. The same codes show up. i have done a quick scan of some hoses and cant seem to find anything, there are no noises either. What are some problematic areas for the 2000 4.0l and if anyone else was experiencing this problem please share thanks.
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #2  
Old 02-19-2011, 06:22 PM
Ford Tough
 
Join Date: Dec 2010
Posts: 418
Default Re: The Infamous P0171 and P0174 codes troubleshooting

there is THIS sticky in the 4.0 section, not sure if the same applies to your ohv engine, though... I'd still have a good look at all the connections between the hoses and what not under the hood.
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #3  
Old 02-19-2011, 06:26 PM
Roll Tide
 
Join Date: Jun 2010
Posts: 732
Default Re: The Infamous P0171 and P0174 codes troubleshooting

Had the same problem for months. I changed the MAF sensor twice (No, I didn't pay for two of them. One was a return) , changed 02 sensors, changed air filter frequently (like that was causin it lol), and changed out rotten vaccum hoses. Only to find out that it was my pcv valve and I had to go buy the whole pcv valve kit.
__________________
20O3 extended cab, 2wd, silver, 3.0, toyo spectrum tires, 10,000k HID's, 8' in bazooka tube, and UWS toolbox
Reply With Quote
  #4  
Old 02-19-2011, 06:48 PM
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 953
Default Re: The Infamous P0171 and P0174 codes troubleshooting

haha wow, maybe that should be where i check next. Where exactly is the pcv valve? and i've already checked the sticky and its not the same as mine
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #5  
Old 02-19-2011, 06:58 PM
Roll Tide
 
Join Date: Jun 2010
Posts: 732
Default Re: The Infamous P0171 and P0174 codes troubleshooting

Driver side of the manifold on the back. I'll try and post a pic.

----------

Here you go. If it doesn't look like this get back on here and let me know.
__________________
20O3 extended cab, 2wd, silver, 3.0, toyo spectrum tires, 10,000k HID's, 8' in bazooka tube, and UWS toolbox
Reply With Quote
  #6  
Old 02-19-2011, 07:10 PM
Ford Tough
 
Join Date: Dec 2010
Posts: 418
Default Re: The Infamous P0171 and P0174 codes troubleshooting

yeah, the sticky (and those codes) are related to the pcv system, so it's very possible that the valve is bad, even given the different setup. If its still throwing codes after a new valve, or if the valve checks out ok, check all the hoses related to the pcv system, and their connectors for cracks/tears, etc.
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #7  
Old 02-19-2011, 07:10 PM
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 953
Default Re: The Infamous P0171 and P0174 codes troubleshooting

i have found it, thanks. I could pull it out fairly easily is this ok? i had also looked at the tubing and it seemed fine.
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #8  
Old 06-20-2014, 11:13 PM
Learning to use the forums
 
Join Date: Jan 2014
Posts: 8
Default Re: The Infamous P0171 and P0174 codes troubleshooting

can someone show me where it is in this picture?





Quote:
Originally Posted by southbama man View Post
Driver side of the manifold on the back. I'll try and post a pic.

----------

Here you go. If it doesn't look like this get back on here and let me know.
Reply With Quote
  #9  
Old 06-21-2014, 04:15 AM
Ford Tough
 
Join Date: Dec 2013
Posts: 440
Default

I had the same codes on my 99 4.0 and I replaced the upper plenum gasket and retorqued the lower intake bolts ... They were only hand tight. It fixed my problem with the lean codes.
__________________
1999 Ranger 4.0 and extreme Snap-on tool fetish
Reply With Quote
  #10  
Old 06-22-2014, 05:52 PM
Ford Ranger Owner
 
Join Date: Feb 2011
Posts: 56
Default

Vacuum clamp all vacuum lines and see if that helps 5\16 clamps fit just right they can be purchased from the hardware store.
Reply With Quote
  #11  
Old 06-22-2014, 10:07 PM
Ford Ranger Owner
 
Join Date: Feb 2011
Posts: 56
Default

Also make sure all additional vapor lines are clamped and free from cracks and holes, for example evaporative emissions lines, positive crankcase ventilation lines, and make sure the air intake manifold T 30 bolts are torqued to the correct specifications 89 in lbs is what the Haynes manual gives.
Reply With Quote
  #12  
Old 07-22-2014, 05:27 PM
Ford Ranger Owner
 
Join Date: Feb 2011
Posts: 56
Default

It also helped to count rpms starting at the top going down until I could settle on the correct rpm range. Intake air temperature may come into play here too. The air box mod if it was done to your vehicle will trigger this code. So try not to change the intake air temperature with fresh air it may create enough of a change to trigger the check engine light
Reply With Quote
Reply

Tags
maf, p0171, p0174, pcv, sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adaptive Fuel DTCs Diagnostic Techniques (P0171/P0174) Jp7 Electrical Tech 4 05-15-2012 03:19 PM
P0171 & p0174 tsmero 4.0 SOHC / 4.0 OHV Tech 2 02-06-2011 06:48 PM
01 Ranger infamous belt squeek? coyote223 4.0 SOHC / 4.0 OHV Tech 11 10-02-2010 06:38 PM
Need help with AutoPage RS-600... Troubleshooting TrePaul86 Electrical Tech 3 02-14-2010 11:06 AM
Ford Rager 1999 codes P0171/174 cliftonfts General Tech 16 01-28-2010 04:18 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.