Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-18-2011, 02:40 PM
Sam G Sam G is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 2
Default Coolant Sensors leak (pouring out!!!!!)

Just pulled into my parking lot last night and I noticed that my engine was running hotter than normal, gage was little past half. I looked under the hood and saw that my thermostat housing was leaking fluid. It was a leak in the gasket between to plasket parts of the housing, kinda hard to explain were the leak was. Its not the thermostat o-ring that was leaking but the housing... Anyways I went ahead a replaced the housing and thermostat thinking it would solve all issues. But just ask I started the engine back up the fluid came pouring out of the two sensor holes on top of the housing. The guy at the dealer ship were I bought the housing said that the new housings don't fit well with the old sensors. I was wondering if anyone knows of a quick cheap fix for this with out buying new sensors. The sensors seemed like they fit when I put them back in but must be off just enough for the o-ring not to compress enough. Does anyone have any ideas on how to fix with out buying new sensors?
__________________
Ford Ranger 4.0L V6 SOHC Edge
No Modifications
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Leak-Where? RangerSteve 3.0 Vulcan Tech 7 07-11-2013 02:30 PM
Coolant leak. cajunclub General Tech 4 10-19-2011 08:03 PM
coolant leak 86rocco 4.0 SOHC / 4.0 OHV Tech 3 02-16-2011 06:34 PM
Coolant leak DieselBrad 4.0 SOHC / 4.0 OHV Tech 0 12-15-2010 03:53 PM
Coolant leak Amsement 4.0 SOHC / 4.0 OHV Tech 8 07-24-2010 01:06 PM