Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-10-2011, 12:33 PM
schl48 schl48 is offline
Learning to use the forums
Join Date: Jan 2011
Posts: 2
Default 99 ranger 4.0 4x4 runs like crap at times but not always

running terrible at times, then runs great.


thats best decribes what happening to my 1999 ford ranger 4.0 auto 4x4 truck.
it will run great after a tune up fuel filter air filter plugs and wires seemed good.
it has 150000 miles. but all of a sudden it starts losing speed 60mph slowing downto 30 to-0 mph and stalls. it starts right back up fine mostly skipping an flubbering. try and rev it up it won't rev up past 2000 rpm hold at 2000 and it may clean out and purr and rev great or it may keep flubbering.this happens idling,driveing,curising,stopping going it don't matter. cked vacurm found a leak and fixed it. this was all done to try and fix it. it did help when it runs now it runs great.but didn't fix it. thanks
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Ranger runs like crap when its cold outside sacalait59 4.0 SOHC / 4.0 OHV Tech 1 12-29-2010 12:47 PM
Ranger runs rough wedge 4-Cylinder Tech 0 08-16-2010 11:17 AM
o crap ranger moment wolfboy192 General Ford Ranger Discussion 15 05-29-2010 09:13 AM
2000 2.5l ranger runs like crap lildevjkoch1977 4-Cylinder Tech 11 04-20-2010 04:39 AM
How many times has someone tried to steal your Ranger? 07XLT General Ford Ranger Discussion 58 02-24-2010 02:56 AM