Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 12-16-2010, 12:35 PM
daniboy daniboy is offline
Learning to use the forums
Join Date: Dec 2010
Posts: 2
Default 10 or less MPG- Help needed

Hey guys got a bit of a situation here. When i got my 1991 ranger a few months ago I was getting 21mpg. I had to replace my slave cylinder and while doing that my o2 sensor fouled out. I replaced the 02 sensor but still only got about 16mpg. I checked for a vacuum leak cause my check engine light would come on and then go off. The vacuum was great and help steady at 18"Hg. I got a scanner and pulled the codes. I fixed two of them and no diff. in the mpg's. I got one other code that said PIP (profile ignition pickup) failure. I am not sure what that means or how to fix it. Also when I tried pulling any codes while the engine was running it would just hold 000. It wouldn't even come up with the number of cylinders in the engine.

So do I need a new PIP sensor? and how do i do it and where is it located at???

Reply With Quote

ignition, mpg

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
More MPG!! bigtoys2004 4-Cylinder Tech 261 05-10-2012 07:14 PM
10 mpg?? SmokeyMcPot420 3.0 Vulcan Tech 12 03-18-2011 09:06 PM
MPG on a 98? dan98ranger 4-Cylinder Tech 4 11-15-2010 01:07 AM
Mpg!!!!! tgroves65 3.0 Vulcan Tech 17 11-02-2010 10:17 AM
20 mpg vapiper General Ford Ranger Discussion 25 10-11-2010 09:57 AM