Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-23-2009, 05:13 AM
Gene Gene is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 2
Default 94 with 4.0 want start

I'm trying to help a neighbor out with his 1994 2 wheel drive 4.0 Ranger, he drove it to the store and then it would not start. I pulled it to my house and I'm trying to fix it for him, I listened for the fuel pump operation and could not hear it working. I switched some of the relays in the control panel and the fuel pump still did not work. I pulled the bed off and removed the fuel pump, I checked the the fuel pump by using jumper wires and found it was bad. I replaced the fuel pump and it still would not start, could not hear it working. I checked the power to the pump and found it's not getting any voltage. I checked the switch that's inside on passenger firewall (ignertia switch?) it was ok. I have fire so I ran two long jumper wires one fused, from the battery to the fuel pump. Pump running, I have pressure at fuel rail but truck still want start. Any suggestions would be greatly appreciated.
Thanks,
Gene
Reply With Quote
  #2  
Old 08-23-2009, 06:47 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Check the fuel filter to see if fuel is getting pass it?
__________________
2005 Edge

Reply With Quote
  #3  
Old 08-23-2009, 07:36 PM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 634
Default

Hmm, there is a little switch on the pass. side that is a common cause to a many a no starts. I would check the voltage across the fuel pump then I would would google "fuel switch passenger side", I am not totally clear as to years applicable but you could find out very easily.
G/L
Reply With Quote
  #4  
Old 08-23-2009, 07:47 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Quote:
Originally Posted by 02'4.04x4 View Post
Hmm, there is a little switch on the pass. side that is a common cause to a many a no starts. I would check the voltage across the fuel pump then I would would google "fuel switch passenger side", I am not totally clear as to years applicable but you could find out very easily.
G/L
He said he checked the inertia switch and it was fine
__________________
2005 Edge

Reply With Quote
  #5  
Old 08-23-2009, 08:46 PM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 634
Default

I see, inertia switch, missed that the first pass(common).
Well I would start with the basics, when trying to diagnose an unknown.
1. timing, (align marks)
2. spark, (pull plug hold electrode to engine metal watch for spark)
If you know the fuel is down, then check the spark and it is a nogo then just get a new dealer key.
3. fuel
4. fuel pressure lbs.
If all these check out shouldn't take more than 30 minutes.
Then I would say it is time for a new Key.
It is possible that the old key's chip failed, I had that happen with the key to my GT3, girl washed it and it failed. Then I could use it as normal but not to start the car. Without the crystal in the key it puts the car into the pats system. In other words the fuel and the ignition cuts out. It would seem to be the case, except for the unusual coincidence of the pump being bad.
You can easily reprogram new keys if you have a working one. But if you have another "key" try it first. If not(more than likely) get a new dealer key.
Ebay keys are knock off China poo and should be avoided.
HTH

Last edited by 02'4.04x4; 08-23-2009 at 09:05 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search