Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-20-2010, 07:38 PM
wallabysailor wallabysailor is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 6
Question Intermittent lack of power and low idle

So here's the history...
Starting about a week ago my little Ranger starting occasionally losing power and running roughly on an occasional basis. Often it would come on as I was going down the freeway at 70 mph.

Over the last week using my manuals and web forums I have replaced the MAF, IACV, air filter and fuel filter. I have checked the PCV and the rubber elbow hose. I can't hear any leaking vacuum hoses.

My ODB II reader has at various times given me P1131, P1151, P1071, P1074 codes. The last test run I made got me P0136 as well as P1131 and P1151.

The odd thing is that it's intermittent. The lack of power and roughness will come on suddently and then if I just chug along it will correct itself and run properly for a few miles before doing it again.

Any ideas?
__________________
Jon
98 XLT
4.0L 5 Sp Manual
XCab 4X4
Reply With Quote
  #2  
Old 11-24-2010, 01:56 AM
wallabysailor wallabysailor is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 6
Default Re: Intermittent lack of power and low idle

No responses? I guess I had a tough one to solve...I'm still trying...
__________________
Jon
98 XLT
4.0L 5 Sp Manual
XCab 4X4
Reply With Quote
  #3  
Old 11-24-2010, 07:44 AM
Lord of War Lord of War is offline
Ford Rangers
 
Join Date: Sep 2009
Posts: 201
Send a message via AIM to Lord of War
Default Re: Intermittent lack of power and low idle

Do you think it could be your fuel pump going bad?

Also have you looked up what those codes mean?
__________________
2002 - XLT, 4.0L, 4x4

3" BL, 295 Nitto Terra Grapplers

K&N FIPK, Dual exhaust
Reply With Quote
  #4  
Old 11-25-2010, 09:53 AM
wallabysailor wallabysailor is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 6
Default Re: Intermittent lack of power and low idle

I haven't quite got to checking the fuel pump yet but I suspect I will be soon.

Another couple of diagnostic clues:

The engine tends to run properly after if first starts. I can drive 5-10 miles with it operating normally before the symptoms start exhibiting themselves again.

The onset of the hesitation/missing/lack of power tends to come on when the engine is running at a constant pace. For example, if I'm on a freeway and staying at a constant 60 mph it will come on more often than if I'm in city traffic where I'm changing speeds/accelerating/decelerating often.

When the symptoms come on I've discovered that if I immediately drop a gear or two and create a vacuum condition in the engine it tends to sort itself out very quickly and return to normal operation.

If I'm driving down the road and I keep accelerating and then taking my foot off the accelerator for a few seconds (i.e. keep the engine under constantly changing load conditions) it will tend to not start missing/losing power/etc.

I've also gone to putting top quality gas in the tank and have put two treatments of injector cleaner through the car.

I'm open to ideas.

Happy Thanksgiving!
__________________
Jon
98 XLT
4.0L 5 Sp Manual
XCab 4X4
Reply With Quote
  #5  
Old 01-16-2011, 09:52 AM
BT24 BT24 is offline
Like the Forums
 
Join Date: Jan 2011
Posts: 44
Default Re: Intermittent lack of power and low idle

if your truck has coil packs..check and or replace them
Reply With Quote
  #6  
Old 01-16-2011, 10:25 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Intermittent lack of power and low idle

Quote:
Originally Posted by BT24 View Post
if your truck has coil packs..check and or replace them
X2, plugs and wires as well
Reply With Quote
  #7  
Old 02-01-2011, 01:00 PM
BT24 BT24 is offline
Like the Forums
 
Join Date: Jan 2011
Posts: 44
Default Re: Intermittent lack of power and low idle

My 1997 2.3 was experiencing the same symptoms...driving me crazy...I changed my alternator and it fixed the majority of my issues...but then I also changed the intake and exhaust manifold gaskets...NAPA has a kit of Felpro gaskets for the intake that come with a gasket for your throttle body...this is where I found my leak..there is a small hose the comes off of the throttle body and snakes through the intake manifold on a small steel tube...it is connected to one of the bolts that screws into the lower half of your intake manifold...it was very cracked on one end... I am going to try and post a pic...
Reply With Quote
  #8  
Old 03-14-2011, 12:26 PM
wallabysailor wallabysailor is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 6
Default Re: Intermittent lack of power and low idle

Okay, so I'm back at it again...I now have:
New ICV
New MAF
New Coil pack
New Plug Wires
Plugs have less than 15k on them

I checked the ECV and it rattles nicely.

Latest twist...I have been driving with the MIL light on for a couple of weeks now. On Saturday I was driving down the freeway and it lost power and started running rough. I managed to get the 15 miles to home and started looking again. For grins I disconnected the MAF..voila the engine ran smooth at idle. I took it for a drive with the MAF disconnected and it ran fine although when I stopped at a light the engine eventually dropped in revs to under 300 and the stalled. It seems if I keep the revs at 1800 - 2000 I can drive it.

I'm checking the MAF connector to check voltage across the A-B and C-D terminals IF I can make it home tonight...
__________________
Jon
98 XLT
4.0L 5 Sp Manual
XCab 4X4
Reply With Quote
  #9  
Old 03-20-2011, 07:24 PM
lostsoul lostsoul is offline
should have cut the blue
 
Join Date: Jan 2010
Posts: 13
Default Re: Intermittent lack of power and low idle

yea sound like some wires may be to dirty or corroded to conduct so i would get some 3m scrubbing pads and some QD elec. cleaner and go to town
Reply With Quote
  #10  
Old 03-22-2011, 01:28 AM
wallabysailor wallabysailor is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 6
Default Re: Intermittent lack of power and low idle

Solved it!!! I checked the fuel pressure at the Schraeder valve on the fuel rail. 23PSI at idle. Changed the fuel pump and instantly it's up to 67PSI at idle and running like a charm...
__________________
Jon
98 XLT
4.0L 5 Sp Manual
XCab 4X4
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
LOW ROUGH IDLE, Sometimes dies! VegasRanger02 3.0 Vulcan Tech 12 04-12-2011 10:06 PM
low idle and low charging gauge big green 4.0 SOHC / 4.0 OHV Tech 6 11-29-2010 05:29 AM
84 2.8L V6 idle is too low to stay running OreEle 2.9 Liter Tech 5 11-10-2010 07:38 AM
2.3L 5 Speed lack of power Deadokie21 4-Cylinder Tech 1 09-20-2010 01:05 AM
Irregular shifting and slight lack of power along with a rattle Am3rican_Rang3r General Tech 5 03-13-2010 02:43 AM