Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-16-2010, 12:42 PM
tiredtruckfixerupper tiredtruckfixerupper is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 10
Default 96 ranger idle issue

hey all i have a 1996 stx 4.0L. upon starting all runs fine until 5 minutes i feel a few misfires and the idle goes down to near stalling and back up and keps doing this. a little shaking and when put in gear (brakes applied) she surges with the idle. new coil pack, wires, plugs, cleaned IAC motor. however when i unplug the TPS nothing happens. could this my issue. i wanna know before i spend the 88 bucks on it
Reply With Quote
  #2  
Old 10-17-2010, 06:48 PM
tiredtruckfixerupper tiredtruckfixerupper is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 10
Default Re: 96 ranger idle issue

figured it out. vacuum hose on the bottom of the plenum (throttle body) was ripped, and bad wire on air temp sensor. ready to go
Reply With Quote
Reply

Tags
6cyl, idle, misfire, stalling, tps

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Idle Throttle Issue 2002 XLT 3.0L Rumble520 General Tech 6 03-29-2013 11:58 AM
wierd little idle issue mehdi1993 3.0 Vulcan Tech 5 02-13-2012 07:30 PM
1998 2.5 engine idle issue, only when cold cf3232 4-Cylinder Tech 12 03-07-2011 11:26 PM
2003 Ranger idle issue zorander6 General Tech 1 08-15-2010 09:22 AM
1989 Ranger Issue kitt1993 4-Cylinder Tech 3 08-09-2010 06:50 PM