Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-26-2010, 02:12 PM
beef08 beef08 is offline
Oh Yup!
 
Join Date: Mar 2010
Posts: 2,695
Default is this normal?

so my check engine light when one and noticed there was a hole in a vacuum hose and replaced it. However my check engine light is still on and in park and nuetral my truck wont rev past 3200rpms or so but when driving all is normal. Is it normal for my 2003 ford ranger xlt to not be able to rev past 3200 rpms in park and nuetral?
__________________
"I thought this was America!"-Randy Marsh

2003 fx4 4.10, maxed tbars, 5000k HIDS 3157 silverstar bulbs, expo ohc, alons mag light holder, 06+ tails, throttle cable mod, air box mod
360tag:BEEFS7A7US
Reply With Quote
  #2  
Old 08-26-2010, 02:16 PM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: is this normal?

Quote:
Originally Posted by beef08 View Post
so my check engine light when one and noticed there was a hole in a vacuum hose and replaced it. However my check engine light is still on and in park and nuetral my truck wont rev past 3200rpms or so but when driving all is normal. Is it normal for my 2003 ford ranger xlt to not be able to rev past 3200 rpms in park and nuetral?
did you unhook the battery for a few minutes to reset the CEL after you fixed the problem? if not, do that. also when in park your truck wont rev past 3000 RPM because it has a rev limiter, so yes, thats normal.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #3  
Old 08-26-2010, 06:04 PM
beef08 beef08 is offline
Oh Yup!
 
Join Date: Mar 2010
Posts: 2,695
Default Re: is this normal?

thats what i thought ..yea i took off the neg cable but only for a couple of seconds so that might be it
__________________
"I thought this was America!"-Randy Marsh

2003 fx4 4.10, maxed tbars, 5000k HIDS 3157 silverstar bulbs, expo ohc, alons mag light holder, 06+ tails, throttle cable mod, air box mod
360tag:BEEFS7A7US
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Clunk" noise under normal acceleration Pielet Drivetrain Tech 12 12-16-2010 12:30 PM
is this a normal lean? FX4 Suspension Tech 12 06-27-2010 03:13 PM
Starting harder than normal? Frez1812 4.0 SOHC / 4.0 OHV Tech 3 05-11-2010 06:38 PM
Running Lean-Whats normal? RangerSteve 3.0 Vulcan Tech 9 02-28-2010 07:40 PM
Is this normal, or am I Wylie Coyote? RangerChad 4.0 SOHC / 4.0 OHV Tech 12 09-23-2009 04:43 PM