Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 08-18-2010, 09:02 PM
RPM9000 RPM9000 is offline
Learning to use the forums
Join Date: Aug 2010
Posts: 2
Default 98 4.0L Missfire/Chugging problem

I have a very frustrating problem which I hope y'all can help me out with. I've had my Ranger for several years now and I keep up on the maintenance pretty well. When I'm driving down the road and I put my foot in it to pass someone on the freeway or go up a hill, etc., my truck will "chug" and hesitate like it's losing power, then once my rpms get above 2000 to 2500 it has no problem. So basically it only does it when there is a load on the engine. I have put plugs, plug wires, new fuel filters, cleaned the MAF, and even a new coil and it doesn't seem to get any better. Could this be a bad catalytic converter, egr, pcv valve, etc. Thanks for all the help guys.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cylinder 4 missfire and lean Kink2227 4-Cylinder Tech 7 08-15-2015 12:39 PM
Cylinder Missfire schumungus 3.0 Vulcan Tech 3 03-17-2012 05:57 PM
chugging idle... recent head gasket job haggisbasher 3.0 Vulcan Tech 3 04-25-2010 05:44 PM
Rough idle, chugging when speeding up. swkarg 4.0 SOHC / 4.0 OHV Tech 5 04-18-2010 11:42 AM
Cylinder 6 Missfire code RangerSteve 3.0 Vulcan Tech 0 02-12-2010 10:42 PM