Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 12-17-2010, 06:22 PM
caryrae73 caryrae73 is offline
Learning to use the forums
 
Join Date: Dec 2010
Posts: 8
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Well I replaced the elbow with the 19/32 hose and it fit good. I let it get up to normal engine temp and so far it seems to idle fine and the CEL hasn't come on after I reset it but will have to see when I can drive it longer and see how it does.
Reply With Quote
  #32  
Old 12-17-2010, 06:24 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Excellent! Good news!! Glad to see you corrected it!
Reply With Quote
  #33  
Old 12-20-2010, 04:27 PM
caryrae73 caryrae73 is offline
Learning to use the forums
 
Join Date: Dec 2010
Posts: 8
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Well after driving to and from work today even with driving home in a snow storm with stop and go traffic my Ranger did great. The CEL hasn't come back on and the engine never stalled or had rough idling while at a stop or going really slow. I think fixing the elbow did the trick and probably saved me a bunch of money not having to bring it in to get looked at.
Reply With Quote
  #34  
Old 12-20-2010, 05:57 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Good deal!!! Glad to hear you're all set!
Reply With Quote
  #35  
Old 01-17-2011, 11:42 AM
christine357 christine357 is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 3
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Thanks guys, I checked the elbow, it is fine. I have a guy that will change the fuel pump for 80.00 if I buy the parts, I think that is a fine deal. We tested to see if there was gas from the pump. there was none. I am hoping that is the problem. The only thing that concerns me is that is could be a faulty security system, but the truck has 129K miles on it, and never had a new pump. So here's crossing my fingers.
Reply With Quote
  #36  
Old 01-17-2011, 12:40 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

That sounds like a good deal!
Reply With Quote
  #37  
Old 03-05-2011, 05:05 AM
Lakeside Lakeside is offline
Love my '97
 
Join Date: Mar 2011
Posts: 7
Send a message via AIM to Lakeside
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

That was great info. That could be what is going on with my '97. I have had those codes come up and makes perfect sense. Will have to check that out. Thanks.
__________________
1997 xlt4x4 4.o. will fill in more info later,
Reply With Quote
  #38  
Old 04-20-2011, 02:28 PM
mdgriff mdgriff is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 7
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Check your gas cap
__________________
2004 XLT 4x4 4.0 5 Spd
Reply With Quote
  #39  
Old 04-20-2011, 07:12 PM
Alon Alon is offline
2AM Fabrication
 
Join Date: Nov 2008
Posts: 809
Send a message via AIM to Alon
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Everyone should check theirs just because!

I didn't have any code but mine was cracked.
__________________
}---------> 2:AM Website <----------> 2:AM Facebook<---------{
Reply With Quote
  #40  
Old 05-02-2011, 07:27 PM
fbref9 fbref9 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 2
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

I have a 2001 Ford Ranger 4x4 X-cab 4.0. It has 150k miles on it. I had a tune up completed last week, and this weekend the engine light went on. I took it back to the shop and they told me the CEL was due to code 171. They wanted to change all of the O2 sensors.

I found this post after doing a few searches. I told them not to do any work on the truck. On my way home I purchased the recommended 5/8 inch hose and made the fix.

If it was not for the post, I would be out $400 instead of the $10 I paid for the hose and clamps.

Thanks!
Reply With Quote
  #41  
Old 07-19-2011, 11:54 AM
Big Blue Evv Big Blue Evv is offline
Rangers for life
 
Join Date: Apr 2011
Posts: 167
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

well i have a 02 ranger with the 4.0L and i checked the hose after seeing this post and shure as shit it was cracked. lets now c after replacing it if it fixes the prob. thanks so much!!!!
Reply With Quote
  #42  
Old 08-11-2011, 09:01 AM
TXCOMT TXCOMT is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 82
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

01:

Thanks for this thread; especially the pics! Turns out I had a seriously gashed elbow like some of the previous posters. You just saved me a ton of time and money. Also, thanks for your (military) service!

Mike H.
__________________
2002 4X4 Edge Plus SuperCab Flareside

Miles? Check.
Mods? Check.
Mine? Check.


Ain't nothin' like a paid-off truck!
Reply With Quote
  #43  
Old 08-11-2011, 11:23 AM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Quote:
Originally Posted by TXCOMT View Post
01:

Thanks for this thread; especially the pics! Turns out I had a seriously gashed elbow like some of the previous posters. You just saved me a ton of time and money. Also, thanks for your (military) service!

Mike H.
Thanks Mike, Im glad that this thread has helped a few people.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #44  
Old 08-27-2011, 03:50 PM
Munki Munki is offline
2003 Edge 3.0
 
Join Date: May 2011
Posts: 145
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Could anybody possibly help me out with finding this elbow or another of the same type that could be causing this problem? Out of the blue last night my truck started idling way high and would go on its own in first or second gear. All I have read on here in multiple posts are that it could be a vacuum line problem or this crack in the pcv elbow. My grandfather who is a mechanic told me to check the vacuum lines and I have been looking and I can't find anything, I just don't know exactly what to look for. Any help would be appreciated. I am also worried I have an exhaust leak the exhaust welds from the p/o don't look all that great to me and seem kind of spotty. They also didn't even put the rear o2 sensor back in.
__________________
2003 Black 3.0 Edge-Manual trans-8.8in 4.10-15x8s w/31x10.50s Magnaflow exhaust
Sonar projector housings and 6000k Hids, Sonar LED tails, LED 3rd brake light & 10" Brembo brake drums, shoes, new valance, & grille, and removed pinstripes
eventually changing to black rims & fixing my o2 sensor, cruise ctrl, & adding buckets
Reply With Quote
  #45  
Old 02-20-2012, 06:27 PM
DiRT__ DiRT__ is offline
Ford Rangers
 
Join Date: Feb 2012
Posts: 202
Default Re: If you have an 01+ 4.0 with lean codes (PO171 and/or PO174) look here!

Just replaced mine last week. Had a gash just as described. Now I'm afraid another one is bad because my AC won't run through the vents, only out the defrost
Reply With Quote
Reply

Tags
elbow, lean codes, o2 sensors, pcv, po171, po174

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cylinder 4 missfire and lean Kink2227 4-Cylinder Tech 7 08-15-2015 12:39 PM
E85 and codes PO171 and PO174 garo24 3.0 Vulcan Tech 18 04-29-2014 10:21 AM
System to Lean Bank 1 & 2 TomN 4.0 SOHC / 4.0 OHV Tech 19 04-12-2011 01:12 PM
is this a normal lean? FX4 Suspension Tech 12 06-27-2010 03:13 PM
95 ranger lean.. camkos Suspension Tech 14 06-19-2009 07:19 AM