Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 01-24-2011, 11:29 AM
Neospyd3r Neospyd3r is offline
Like the Forums
 
Join Date: Mar 2010
Posts: 33
Default Re: System to Lean Bank 1 & 2

Grab a can of brake clean spray around your intake system ie; hoses, manifold, sensors, etc... (spray lightly - try not to saturate) if there is a vacuum leak your idle will fluctuate when the pirate air leak is sucking in the solution, if no fluctuation may be a fuel problem - vacuum leak is most likely
__________________
2008 Ranger Sport 4x4 4.0L.
- Custom Torsion / Block 2.25"F 1.75"R - 4.10 LSD Rear diff / 4.10 front (yukon)
- Borla Exhaust - Superchips Programmer
- 265/75R16 Bridgestone A/T Revo II's
- Custom Intake K&N / AirAid Modded by me - Custom Throttle Body 76mm
- H10 HID's 3000k (fog)... etc...
Reply With Quote
  #17  
Old 02-20-2011, 10:59 PM
ranger1998 ranger1998 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 1
Default Re: System to Lean Bank 1 & 2

Quote:
Originally Posted by svtwin73 View Post
I have the same problem with the codes, I had to replace the lower intake gaskets. Also while I was in there, I had to replace the lower intake manifold gasket. Had a small leak from the back passenger side of the manifold. It's an easy fix.
care to elaborate? my ranger is throwing same codes. cleaned the MAF sensor and it was good for about 80 miles that bitch slapped with the check engine light again. my gut tells me its the intake manifold gasket and i DO NOT want to do it. but please tell me how its an easy fix, seems like a bear of a fix to me! thanks
Reply With Quote
  #18  
Old 02-21-2011, 05:52 AM
svtwin73 svtwin73 is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 310
Default Re: System to Lean Bank 1 & 2

It's a real easy fix, just takes a little time only because you have to take it apart. Biggest headache in it is removing the tube on the front left side. Parts are less the $100
Reply With Quote
  #19  
Old 02-21-2011, 01:18 PM
shuvelhead2009 shuvelhead2009 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 3
Default Re: System to Lean Bank 1 & 2

well i got the same code bank 1 and 2 running lean i have actually replaced all sensors and vac lines ,wires , plugs , main computer , injectors , complete distributer,fuel filter and she runs great for a day the prob is the only thing i did not do is the fuel pump i hope any one know what it could possibly be i took her to ford and the guy said try a different dealer cause the codes are too wide spread so after all the work i HAVE DONE its not fixed and if any one knows the propper sequence of events i have to do for continual test for obd 2 i would apprecieate it for a 1999 3 liter auto with air i can let any one know exactily what i did just email me and i will pass it on shuvelhead2009@live.com or leave me a note on here thanks
Reply With Quote
  #20  
Old 04-12-2011, 01:12 PM
nac5096 nac5096 is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 1
Default Re: System to Lean Bank 1 & 2

Hello All,

1998 ranger 4.0L XLT Supercap 4x4

Throwing CEL for P0171 and P0174

Things done:
-all O2 sensors 1 yr old
-S-Plugs only 6 months old
-Fuel filter 1.5 yrs old
-Replaced fuel pressure regulator thing
-Cleaned mass air flow sensor
-Cleaned IAC valve
-Mass Air reading correctly when connected to computer
-Checked for vaccuum leaks all around truck found small one in lower intake manifold
-Replaced upper and lower intake manifold gaskets and valve cover gaskets and reassembled... changed oil etc...

Still throws boths codes

What is the spec on the fuel pressure at the rail?

I have seen that it was something like 48 psi +/-12 psi but not sure..

I have 34 psi on the rail.. Is that low fuel pressure enough in itself to throw lean codes on both banks?


Thnx in advance for any help!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light "p0174 system too lean bank 2" bordum128 3.0 Vulcan Tech 6 04-02-2012 04:35 PM
P0174 System Too Lean bank-2??? bordum128 Electrical Tech 2 12-14-2010 06:55 AM
New & Improved Invite System Tom Site Announcements, Comments and Suggestions 4 03-11-2010 07:38 AM
98 ranger P0171 system too lean (bank 1) JSIMON73731 4-Cylinder Tech 5 08-02-2009 09:42 AM
have ford ranger pickup, says lean bank 1&2? lordy327 General Ford Ranger Discussion 1 11-26-2008 11:11 PM