Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-23-2010, 08:52 AM
CornFedBeast CornFedBeast is offline
Liking the Ford Ranger Forum
Join Date: Feb 2010
Posts: 24
Default AC clutch not engaging, tried adding r134a

So I was going to add recharge my ac system, but when i went to do this I noticed the ac clutch was not engaging at all. So thinking the pressure was too low for it to engage, i added some r134a then it engaged for half a second then disengaged. when it did this the rpms fluctuated so i stopped adding refrigerant and turned off the truck. I am not very experienced in this area and only know what i do from what we briefly talked about in auto class, any help is appreciated. Also when I stopped it was at about 35 psi on the low side and was 80* outside, if that matters.
1997 Ford Ranger XLT 4.0L V6
1984 Yamaha YTM200E Tri-Moto
In Progress:
1971/1972? Rupp Roadster 2
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Inconsistant Clutch engaging problems medeirosnich Drivetrain Tech 9 02-19-2012 10:31 AM
clutch not engaging properly campbellpe70 Drivetrain Tech 4 12-01-2010 09:11 AM
4x4 not engaging properly. john_boi Drivetrain Tech 0 06-09-2010 06:01 PM
4 wheel drive not engaging. z1mms Drivetrain Tech 1 02-14-2010 02:40 PM
4wd not engaging 88ranger Drivetrain Tech 3 01-16-2010 10:55 AM