Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-11-2010, 05:06 PM
cobrajocky cobrajocky is offline
Learning to use the forums
Join Date: Jul 2010
Posts: 5
Exclamation '97 4.0L sometimes won't start, but "turns over"

Hi Guys (and Gals),
I hope you don't mind, but I have a 4.0 L Ranger in sheep's clothing - a Mazda B4000 Extra Cab, that;s obviously really a Ranger out of the same Ford Plant. However, there don't seem to be any Mazda equiv enthusiast "help" sites (Duh, wonder why?), so please help me if you would.

I have a 1997 Mazda B4000 V6 (same as a Ranger 4.0 liter) PU 2WD, only 80k miles, had the CPS replaced 20k ago. For no reason at all, on occasion with no predictability or reason, from cold only, the motor will crank and crank and crank but will not start for hours or the whole day or two. I'll come back later and bang it starts. Once or twice I've heard it backfire through the intake manifold. It has never done this hot, never two days in a row and it only has been doing this about a year, well after replacing the CPS. It may only happen once a week, or again after 2 weeks, or once a month! Sometimes it'll happen two or three days in a row! Nuts!?

We checked for spark when it does this and no spark, but there is a minor smell of gas. So I've replaced the distrib coil. I was going to replace the Ignition Module, but the Mazda dealer parts guys laughed and said they virtually have no history of these failing, none even in stock, even from the warehouse! The Mazda techs said they can't think of a specific reason and can't diagnose it unless it's dead ... wanted to have me leave it there, even though I told them it may not happen for a week or two or more! It's my only transportation, so can't do that.

What the heck is the problem with this truck????

Last edited by cobrajocky; 07-12-2010 at 11:00 AM.
Reply With Quote

mazda b4000 won't start

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light "p0174 system too lean bank 2" bordum128 3.0 Vulcan Tech 6 04-02-2012 04:35 PM
PIC REQUEST: 33"x12.5" tire on 10" Wheel DisturbedESV Wheels and Tires 21 09-27-2011 10:16 AM
I want to upgrade the sound system in my "1988 Ford Ranger XLT".? Jared B Audio / Video 6 08-08-2010 08:36 PM
For Sale: 04' Ranger Edge - 2wd - 3" Body Lift - 33" All terrains BigT8600 Trucks 0 07-04-2010 05:21 AM
Want to Buy: 33" or 32" Mud Terrian tires for 15" rim (IN) 88DangerRanger Tire & Wheel Items 2 01-05-2010 04:55 PM