Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-27-2018, 07:05 PM
DangerFX4Ranger DangerFX4Ranger is offline
Like the Forums
 
Join Date: Feb 2016
Posts: 47
Default Thermostat sensors wet and showing corrosion, rest of housing appearing dry

So I know that a common problem on these OHC 4.0 engines is the thermostat housing will crack or leak coolant. Now looking under the hood, the assembly looks dry but what I AM seeing is the sensors are wet and corrosion is around where the sensors screw or plug into the housing.

Is it possible that it could just be the sensors that need replacement and not the whole assembly? I'm trying to avoid having to get into a costly repair since I know labor costs can shank your wallet hard. It's beginning to get where it will leave wet spots under the truck where the coolant has trickled down to the A-arm and drips off of it. I also had to fill up my overflow tank yesterday so it is leaking, I just don't know if and when it'll get worse. TIA!
Reply With Quote
  #2  
Old 01-27-2018, 08:47 PM
99Ranger376 99Ranger376 is offline
Still around
 
Join Date: Jun 2012
Posts: 2,296
Default Re: Thermostat sensors wet and showing corrosion, rest of housing appearing dry

Itís not even the sensor, sounds like it is the O-right on the sensor. The sensors are sealed with an o-ring and are held in with a u-shaped clip.


Sent from my iPhone using Tapatalk
__________________
2011 Ranger XLT 4x4 3.73 8.8" Trac-lok #1 T-bars, K -springs, LineX bedliner, General Grabber AT2's, Tonnopro tri-fold, CoverKing Realtree AP seat covers, OEM pre-keys, axle spacers, Bilstein 4600's, Hellwig AAL. Ziebart Undercoat
'98 Ranger XLT 2WD (sold)
Reply With Quote
  #3  
Old 01-27-2018, 10:44 PM
DangerFX4Ranger DangerFX4Ranger is offline
Like the Forums
 
Join Date: Feb 2016
Posts: 47
Default Re: Thermostat sensors wet and showing corrosion, rest of housing appearing dry

Well I wasn't sure how the sensor is held into the housing so I just kinda took a stab in the dark. The truck does have 193k miles so it does make sense that the 0-rings have most likely worn out. I'd post a picture of it on here but I'm not familiar on how to do it from mobile.
Reply With Quote
  #4  
Old 01-28-2018, 04:00 PM
99Ranger376 99Ranger376 is offline
Still around
 
Join Date: Jun 2012
Posts: 2,296
Default Re: Thermostat sensors wet and showing corrosion, rest of housing appearing dry

Honestly you might as well replace the sensor because you have to do the same amount of work and finding the correct o-ring is a pain in the ass


Sent from my iPhone using Tapatalk
__________________
2011 Ranger XLT 4x4 3.73 8.8" Trac-lok #1 T-bars, K -springs, LineX bedliner, General Grabber AT2's, Tonnopro tri-fold, CoverKing Realtree AP seat covers, OEM pre-keys, axle spacers, Bilstein 4600's, Hellwig AAL. Ziebart Undercoat
'98 Ranger XLT 2WD (sold)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat housing sensors 2006 4.0 V6 paulmunday 4.0 SOHC / 4.0 OHV Tech 4 06-11-2015 09:45 AM
Thermostat Housing pcityranger 4.0 SOHC / 4.0 OHV Tech 6 12-28-2014 08:25 PM
THERMOSTAT HOUSING 94 xlt 4wd 4.0L v6 1987fordranger 4.0 SOHC / 4.0 OHV Tech 4 01-20-2014 10:50 AM
Thermostat housing ???? Shredxcam 4-Cylinder Tech 11 04-16-2013 06:02 AM
Thermostat Housing nickis General Ford Ranger Discussion 3 12-26-2009 01:03 PM