Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-19-2017, 12:14 PM
Grizzlysam Grizzlysam is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 23
Default Temperature gauge issues

I have a 98 xlt 4.0.

Truck has been out of service for a while and finally recently got it running again. Been driving around town for a few weeks, with no real issues, but after 1 or 2 days of recent highway driving, the temperature guage jumped up to H and stayed there. Even after truck fully cooled down.

Today I replaced the thermostat and temperature SENDING unit, but not the temperature SENSOR for the PCM.

As soon as I got it back together and started it up, the gauge went straight to C. But as I test drove it, the gauge stayed pegged on C the whole time. Even after going on the interstate for a few minutes.

Should I have replaced the SENSOR also?

Thanks in advance.
__________________
98 Ranger XLT 4.0L V6
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 Mazda B3000/Ford Ranger fuel gauge and temperature gauge not working? Adam T Electrical Tech 6 03-30-2014 12:11 PM
temperature gauge? rangerdanger144 Electrical Tech 0 06-18-2013 06:48 PM
Temperature Gauge and Check Gauge light Lonewolf274 3.0 Vulcan Tech 0 01-09-2012 11:56 AM
Temperature Gauge Issues onerinconhill 3.0 Vulcan Tech 8 04-28-2010 08:37 AM
Outside air temperature gauge Roddy Interior Tech 18 01-01-2010 08:53 PM